945 appears to have lost GPS 32 metres into Open Water Swim

Hi guys

Another potential issue here.

I used my 945 for the first time in a lake swim, and after swimming for 1h 7 m and what should have been a 3100 metre swim only recorded as 32 m on the watch.

On checking on Garmin Connect this morning, it only recorded the first 32 metres of the swim and then seems to have lost GPS.

I have recorded stroke rate however through the swim and of course, pressed the lap button on each lap. So the watch was still actively recording the swim, just not the distance.

I am swimming again on Saturday or Sunday, so i will update further if this issue continues.

If it does, I will log it with Garmin.

Regards

James

  • Hi James

    I've had the same thing happen to me. I swam approx 3500 yards (7 laps of my local lake) this morning and after 89 yards, the GPS track stopped, but the timer, stroke rate etc all recorded. I've set GPS and GLOSNAS for Open Water Swimming. My other half has a 945 and her track is fine - hers is just set to GPS. I've attached the FIT file if anyone can shed any light?2019-06-01-10-26-54.zip

  • - are your devices set for '1 second recording' or 'smart recording'?  If set for 'smart recording' then give '1 second recording' a shot.

    cheers
    Mike

  • I'd log this with Garmin now. It's been reported elsewhere so it's not just a problem with the 945. In the meantime while Garmin try to work out where the problem is think about stopping a few minutes into your swim and have a look and see if your GPS is tracking. If it's not, lift the watch clear of the water until it catches up. From then on, it should hold the signal for the rest of the swim. If you are stopping to press the lap button on each lap, make that an opportunity to have a look at the GPS too. I know it's not ideal, but that's probably the best you can do for now.

    I accept that is a bit more of a challenge in an event.

  • What was your swimming style? The watch won't record any distance when doing breaststroke.

  • I've had similar problems with mine. Have done two triathlons with it and distance recorded was less than 100m on both occasions. I tried  GPS and GPS + Glonass with similar results (I remember Gps only working better on the 935)

    Mine is set to 1sec and records the GPS track for the first few meters of the swim and then nothing until i get out of the water so looks like something related to the GPS chip not getting good reception... I am going to report this to Garmin and see if they release a new firmware. In the meantime i'll go back to the 935 for races.

  • same here. Did 2 Triathlons where only about 80m were tracked. First with GPS+Glonass and Smart recording. 2nd,GPS only with 1s recording. Freestyle of course. My swimming style never seemed  to be a problem with my former Fenix and Forerunner watches though Slight smile

  • My Open water Swimming today... 

    Recorded nothing, as soon as I entered the water....

    and really need to geht the TRI Chest Strap for swimming :((((((

  • Same here, two different ocean open water swims stopped tracking early on. First swim was gps +galileo and stopped at 94 yards (out of 3600+) but kept timing and stroke count. Tried to fix it during the swim but no luck. (Had my 920 on a float so I did record the distance.) Second swim (yesterday) with just GPS lasted for 150y or so (out of 3000+); timing and stroke continued. 920 again recorded the swim on a float. 920 also has recorded similar swims over the years with no problem while strapped to my wrist. 

  • Same for me... No distance or GPS trail recorded during OWS.

  • Hi Mike, I am set for smart recording, but my swim at the weekend in the same lake as before did record ok. It will be a suck it and see affair from now on, and i will log it with Garmin if it happens again. I am in the lake 2-3 times a week up to IM UK now, so I will update further if it happens again.