Jabra Elite 65t connection drops due to Dynamic Running Pod

My Jabra Elite 65t has issues connecting to FR245M

 I finally got it to work by turning off wifi and blutooth on my Samsung Galaxy S10+.  Then, connection dropped when the Dynamic Running Pod turned on.

How do I get my earbuds and Dynamic Running Pod to both connect and work with FR245M?

Thank you, 

Dave

---------------------------------------------------------

UPDATE:  I bypassed the above issue by downloading a Spotify running playlist to my FR245M.  I listen to this playlist when I run and leave my phone at home.

Also,  Garmin functionality has so much to offer that I just flat out stopped using Aaptiv workouts (Aaptiv required me to use my phone when running).  At some point, I'll probably want to go back to using Aaptiv and will require my phone when I run so I'll have to figure out a resolution to the above dilemma.  Not sure how I'd have my ear buds connected to my phone for Aaptiv and also connected to my FR245M to get voice alerts.

  • Do you have any other ANT+ sensors connected to your 245, and if so, do they cause this same symptom? 

    Since your RD Pod is broadcasting over a different channel entirely, there's no reason it should be causing interference like this. 

    Also, when this connection drops, if you continue with your activity does the signal ever reconnect? 

  • The extent of my devices:

    1.  Garmin FR245M
    2.  Garmin Dynamic Running Pod  (this is my only ANT+ device - right?)
    3.  Samsung S10+ phone
    4.  Jabra Elite 65t ear buds

    Scenario 1 - using Jabra ear buds with my garmin FR245M watch

    1.  Connect Jabra to Garmin - worked
    2.  Turn on music through Spotify on watch - worked
    3.  Attach Running Pod
    4.  Start Activity for Pod to be activated - Jabra connection drops
    5.  Pod turns on from me moving
    6.  Reconnect watch to Jabra - works...and music starts back up.

    This is all good now.  All appears to work.

    7.  Discarding activity drops connection to Jabra.

    Then when I reconnect Jabra, the music automatically plays for 1 second, then it goes into endless loop of drop connection for 1 second, then reconnect and play music for 1 second, then drop connection and reconnect etc.

    I then put Jabra back in their case.  Same behavior when try connecting Jabra again.  This doesn't resolve itself until the Running Pod registers on my watch as disconnected.

    ------------------------------------------------

    Scenario 2:  using Jabra ear buds with my phone while using garmin watch

    1.  Listening to music on my Samsung S10+ phone with my Jabra Elite 65t ear buds
    2.  Start activity on garmin FR245M - causes Jabra to disconnect from my phone even though they are "not connected" to my watch.
    3.  I run into the endless loop of the Jabra ear buds connecting and disconnecting from my phone.

    Ending the activity on my watch has no effect on the connect/reconnect issue.

    The only way to resolve this issue is to turn off bluetooth on my phone and put the ear buds back in the case.  Then (with no activity running on watch), I turn bluetooth back on on the phone and the music from my phone works correctly with the Jabra ear buds.

    The conclusion:  If an activity is running or stopped on garmin watch then my Jabra ear buds do not stay connected to my phone.

  • Same issue here! Is there a solution found already?

    As soon as I start an activity, the connection drops. Tried everything and even with Bluetooth on my fr245 turned off, the same issue appears.

  • sadly I am having the same issue, but even if i don't have the running pod connected, I get dropped as soon as i start the activity on my Garmin Forerunner 245

  • I have the same exact issue - Jabra Elite 65t + FR245M. When I start activity, it goes into that 1 sec connected-disconnected loop. With other bluetooth earphones it works as expected.

  • how long have you had your Elites?

  • I have Elites for 3 months and FR245M for 1 day:)

  • What works for me:
    - unpair buds from FR245M.

    - unpair buds from phone.

    - pair with FR245M. It asked me whether to pair as foot pod, I chose no.

    Now it works ok. I pull buds from the case. On the watch choose music, it finds the buds and starts playing. I start a running workout and the music keeps playing.

  • Similar issue here: FR245M with Jabra Elite active 65t: it plays music fine until you start an activity, then it starts to endlessly connect/drop/.. After x minutes, things stabilize and it is able to connect without any quality issue anymore.

    I have also tested it with my Sony WF-1000XM3 earbuds: the moment you open the activity screen, the music is constantly dropping, however these earbuds do not disconnect. The moment you go to the main screen, the music quality is perfect. Here as well: after a while the issue seems to disappear, until the next time you want to go for a run.

    So my conclusion is that this is caused by the watch, not the earbud.