The HR sensor on my Fenix 5 plus doesn't work even when it's on "AUTO" in the settings

I've had my watch for 3 months now and everything worked fine til a couple of days ago. I went running and realized in the middle of the run that my HR sensor wasn't working. I turned off the watch and on again and it worked again. Then on the same day while at the office i noticed that it wasn't working again. I researched here and someone said it should be on "auto" and when i went in the settings to my surprise the HR was turned off. So i turned it to auto. Yesterday before my run i made sure it was working but during my run it didn't work again. After the run i checked the setting and it was still on auto. Last night before going to bed wearing it HR sensor was working but when i woke up this morning it wasn't again. It's getting a little frustrating. Has this happen to anyone here?

I tried to email Garmin a while ago through this site and after filling in all the details to email, the "send email" button doesn't even work. I will call their support in an hour when they open but was hoping i can get some answers here what to do.