Neo 2t bluetooth and ant+ not working

I bought a Tacx Neo 2T on the weekend, took it home, set it up and rode Zwift for 30 minutes to try it out. Paired right away the first time without any problems. After my ride I downloaded the Tacx utility app to update the firmware. 

Immediately following the firmware update I tried logging back into zwift, unfortunately the trainer was not able to connect with my mac mini (2019). I did all the things I'm used to doing in this situation, restarting devices, unplugging and plugging devices back in, closing and opening apps. I turned the bluetooth off on my phone, then turned my phone off altogether so it did not interfere with the Tacx trying to connect with the computer. Still nothing. Fast forward a day later, I tried seeing if the Tacx would connect to my macbook pro, which I used many times to run zwift with my Wahoo Kickr. Still doesn't recognize the trainer. I once again opened the utility app, which does recognize the trainer, this time I watched the bluetooth light on the side of the trainer to see what was going on. Turns on when connected to the app then off when I disconnect it. Other than the phone app the bluetooth light never comes on.

So then I pulled out an old ant+ dongle to see if that would work as I am getting sick of this trainer not working. Still won't connect and Zwift still cannot detect it. 

I'm starting to get fed up with this trainer and am ready to return it. I owned a Tacx years ago and got rid of it because of problems like this. I have onwed several Wahoo trainers since then and have not had a problem, is it just my luck?

Why did it work before updating the software and now won't connect at all, no matter what I do?

Hopefully someone has a solution, I really like the idea of this new 2T.