Bluetooth drops

Hi, I just got a new Flux S Smart T2900 on Monday. Since then I've done two races on Zwift using it, and in both races I've had the Bluetooth connection drop out with a few KM to go. Very frustrating, and I was close to throwing my bike out the window.

The firmware version is 3.3.40/1.1.6 out of the box.

I'm running Zwift on Windows, and the Zwift Companion app on my phone (all latest versions). Prior to this, I was using a Satori Smart and didn't experience this issue.

When the signal drops out, the watts readout reads -- as does cadence. Looking in the Zwift pairing screen, it still shows Tacx Flux as Connected, but NO SIGNAL. I have to unpair and pair again a few times before the signal comes back, and that takes about 2 minutes to reestablish.

I'm not running any other bluetooth devices in the home, and both my laptop and my phone are connected to my WiFi via the 5GHz spectrum.

Can someone please assist?


  • Open the Tacx Utility app on your phone and connect it to your bike. Then find and disable the cadence/speed via ant+ if you only use bluetooth. That's what the user meant. It didn't help me, but perhaps you're lucky.

  • I am having a similar issue where my trainer drops bluetooth then it will not require. 

  • Looks like after 2 years the same issue still happens what a dishrace Garmin is..... 

  • I have the same problem - sometimes powering down the trainer helps, sometimes not. In desperation I’ve tried pairing via the companion app but there a lot of lag, so power output / load surges, it’s not a usable option. I’m running Zwift on Apple TV, so connections are all Bluetooth. A solution from Garmin would be good

  • Same, 3km to go on tonight's TTT, still pedaling to keep the trainer connected as we rode down Waitopia KOM drop out, we were pushing for a course record too. I can't handle though, makes me so mad. I hate this device.

  • solution from Garmin would be good

    And @nzmojo 

    Garmin staff very very rarely review or comment on these posts, have you taken up these issues with your local Garmin support otherwise you are wasting your time posting other than for passing on a solution support might provide, I have found support helpful , good luck as I can understand your frustrations

    ps, a common issue can be the trainer is connected to multiple BT and/or ANT+ apps, devices etc and can get confused, try to limit multiple connections to the minimum necessary and try to avoid having both BT & ANT connections at the same time

  • Hi everyone. It’s August 2022 and I have absolutely the same issue.

    I tried switching off that ANT+ setting through the Tacx app, but it lasted for a week and a half and now my Bluetooth connection to iPhone is getting lost again.

    I was wondering if this is happening only with Flux trainers, because I’m going to return my unit and thinking of getting Neo 2T instead. Or should I better opt for Wahoo?


  • Mine behaves the same but only when pairing it also with the Edge 530. I want to have my workouts recorded in a Garmin device, either watch (with Fenix there is no problem) or Edge 530, to get the training status and other stats. But immediately after I start the workout, when I connect the Edge 530, the Tacx app (running on iPad) seems to disconnect from Flux S trainer and the ERG mode is going crazy. It used to do the same when I forgot to close BT connection on the iPhone. This seems legit, as they say there is only one BT connection supported on Flux. And both Ipad and iPhone use BT, not ANT+. But the Edge 530 is using ANT+ when pairing with the Flux sensors (cad/speed and power) so I don't get it why it disconnects the BT connection with the tablet (and Tacx app). 

    You guys, who encounter the same issue, are you connected to a Garmin Edge device, together with an app (such as Zwift, Tacx etc.)? 

  • I've noticed that my Tacx Flux S and Sterzo steering can connect directly to my AppleTV or via the Companion App on my iPone. My recollection is that I began having this BT disconnect issue after I noticed that the devices were connecting through the iPhone Companion App instead of directly. I could not figure out how to connect back directly without removing the Zwift app from the Apple TV, reinstalling and reconnecting. So far so good with the direct connection, but I miss the companion app. Will ride without the companion app and see how it goes.

  • Garmin Support just solved that out for me. It seemed that my watch was connected to the trainer at the same time, while the trainer is designed to be conncted to only one device so the watch and the app (on iphone) were battling for it, therefore connection was lost randomly.