Bluetooth drops

Hi, I just got a new Flux S Smart T2900 on Monday. Since then I've done two races on Zwift using it, and in both races I've had the Bluetooth connection drop out with a few KM to go. Very frustrating, and I was close to throwing my bike out the window.

The firmware version is 3.3.40/1.1.6 out of the box.

I'm running Zwift on Windows, and the Zwift Companion app on my phone (all latest versions). Prior to this, I was using a Satori Smart and didn't experience this issue.

When the signal drops out, the watts readout reads -- as does cadence. Looking in the Zwift pairing screen, it still shows Tacx Flux as Connected, but NO SIGNAL. I have to unpair and pair again a few times before the signal comes back, and that takes about 2 minutes to reestablish.

I'm not running any other bluetooth devices in the home, and both my laptop and my phone are connected to my WiFi via the 5GHz spectrum.

Can someone please assist?

Thanks!

Parents
  • Hi, I'm having the same issue. When the connection drops, I see no signal so I unplug and replug the trainer and sometimes It works again, sometimes it does not and i'm f*cked. I also have issues with the erg mode. Sometimes it won't work even if it is enabled on zwift... I feel you when you say that you want to throw your bike out the window... I got my power unit replaced but the new one starts to do the same thing. My Gf has the exact same model and have experienced these issues only once or twice while I have issues every other ride. 
    I just read on the web people solved this issue by pairing everything but the controller using bluetooth and use ANT+ dongle to connect the controller. I will try this setup next time I ride... 
    Hope this can helps

Reply
  • Hi, I'm having the same issue. When the connection drops, I see no signal so I unplug and replug the trainer and sometimes It works again, sometimes it does not and i'm f*cked. I also have issues with the erg mode. Sometimes it won't work even if it is enabled on zwift... I feel you when you say that you want to throw your bike out the window... I got my power unit replaced but the new one starts to do the same thing. My Gf has the exact same model and have experienced these issues only once or twice while I have issues every other ride. 
    I just read on the web people solved this issue by pairing everything but the controller using bluetooth and use ANT+ dongle to connect the controller. I will try this setup next time I ride... 
    Hope this can helps

Children
No Data