Tacx Flow Smart - Something went wrong during calibration


So yeah, got a tacx flow smart. Got everything setup and was gonna do the calibration.

First time we got the screen where it said we had to tighten it, so we did. After that all we get is:
Your trainer is not calibrated. Something went wrong during calibration. Try again, or visit our support page for additional information.

And of course the support page is utterly lacking of any useful information. Yes the tire pressure is right, Yes it has been warmed up and so on and so forth...
We've tried clearing the app data and reinstalling it. And also on another phone. Same issue every time now.
Also tried loosening it again to try and get the first message once more but no luck.

So, have anyone run into this and found a solution?

Thankful for any information!

  • Or if you have a Garmin Edge device x20/x30/x40 you can calibrate via the edge .

    Calibration on Tacx trainers is a mystery, at least to me. I had a Flow and it would NEVER calibrate via the app ALWAYS "too loose" , I broke the blue wheel thing tightening the thing but it calibrated always via my 530 and that seemed to "flow" over to using the app.

    A stupid thing that I am I eventually got a Flux, it calibrated ok with the 530 or the app

    Then I got a 1040, for a few months it too would calibrate the Flux but after the latest 1040 software update it stopped and wont do it now but app ok?

    You would expect devices by Garmin to work well together but no. The Flux has other issues and while it is to heavy to chuck thru the neared window I very much doubt I will buy a Tacx trainer ever again.

    PS I much preferred the Flow, it is a good trainer but mine blew some internal component when I turned it on one day and never went again.