This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Cannot disable adaptive brightness

I have Venu 2 Plus for two days, yesterday, right after setup, i was able to successfully set screen brightness to max level and disable adaptive brightness, but today, after i woke up, i have noticed that now adaptive brightness is effectively always active regardless actual settings, which seems to being just ignored and doesn't have any effect. I think watch was updated during the night and some bug was introduced in this functionality.

  • I have the same issue. There are a half dozen postings on Redit about this issue. I contacted tech support and they reported others having this issue. They think it'll be fixed with a SW update at some point but not timeline. I'm within the 30 day return window, so I'm sending it back and will probably by the Venu 2 (non-Plus) instead. Or I might just keep using my Vivo Active 2, despite that the battery life sucks. I'm not optimistic about this being fixed soon.

  • I also have issues with the brightness. There is no difference between auto brightness on and off. Also, changing the brightness setttings (brighter/dimmer) doesn't change anything. With auto brightness turned on and off, the display is too dim in dark(er) conditions. For me it's often unreadable in those cases. I want to use the auto brightness, but with increased brightness in dark(er) condititions. That should work, but it doesn't. If this can't be fxed, I'll have to return the watch. Disappointed

  • All-

    Thank you for your participation in this forum thread.  So that I may assist you further, please reply with the following:

    1. May we, if necessary, have permission to email you?
    2. May we, if necessary, have permission to view/access your Garmin Connect account?
    3. In what country do you live?
  • Same issue for me. 



    1. Yes
    2. Yes
    3. The Netherlands 

  • 1. Yes.

    2. Yes. 

    3. The Netherlands.

  • 1. Yes
    2. Yes
    3. Poland

  • 1. Yes

    2. Yes

    3. USA

  • 1. yes

    2. yes

    3. USA

    I have the same issues with auto brightness maintaining control. Update 7.4 had no effect on that issue.

    Update 7.4 did fix the issue with always on display not functioning.

    An oddity with brightness-  as usual with auto dimming off and brightness at 100% if you darken the room the display will dim. The only exception I've found is if I go into the Battery Manager and enable Battery Saver the next page which describes all the processes changed will always go full blast brightness. Auto dimming takes back control once you leave that page though.

  • Yes, I noticed the same thing about Battery Management going full brightness (even in a dark room) for a second or two when it’s activated. But the message that’s displayed at full brightness says that power to the display is set at low and then it switches to the low brightness display even if you stay on that screen. 

  • I'm on 7.4 and still there is this brightness bug...

    So

    1. yes

    2. yes

    3. Germany