This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Edge explore not syncing

Syncing had been getting slower and slower and I was frequently having to manually sync. Now, the only way I get it to sync after I save a ride is to restart my phone and manually sync in the Connect app. I have a Pixel 6a, running Android 13 (build TQ2A.230305,008.E1). Garmin Connect is version 4.65.1. My Edge Explore 2 is running 7.09. The device shows as connected properly in the app (I see the green dot around the circle).

  • It has always showed as connected. The only permission that wasn't on was "Files & Media". I've turned that on and will try again tomorrow (not sure why that would matter, but it does say "some features may not work if not granted").

  • It is a Problem on Garmin Software. Only the first Connect work fine. Next Day Bluetooth connected but it doesn't sync.I Test it with Huawei P30 pro and Google Pixel 7 pro and have the same Problem

  • I have similar problem between my fenix6 watch and GarminConnect on my Android. Now that i read your post i start to think that the problem is in the android app rather than in the Garmin device.

  • Turning on the Files & Media may have helped. It's still not as fast as it used to be, but did autosync without a restart after I saved my ride.

  • something strange happened on mine tonight!

    Phone connection needed re-established and then when I tried to upload tonight's race it wasn't there but the Garmin had uploaded about 20 historic rides from Garmin connect to the Garmin

    I delete all rides after uploading to try and keep uploads fast.........


  • Where did you turn on files and media? I'm having the same sync issues with Edge Explore 2.

  • I have Android 13. It looks like the permissions names or what is required have changed. I no longer see "Files and media", but now have "Music and Audio" and "Photos and Videos".  On the phone, Settings->Apps then find "Connect", then Permissions  I have continued to have some problems with syncing - not as bad as when I first reported this, but still takes longer than it did when I first got the device.

  • I have Android 13 also. I've tried just about everything. The only way it will upload a ride is if I connect to my PC and use Garmin Express. That's more a a hassle I want to deal with. I'm afraid this is going back (30 day window) and try another bike computer (not Explore 2). This would have been perfect if it had worked. Thanks for getting back to me.

  • My device has had issues connecting to Macbook Pro M1 with USB-C cable from day one. Different cables tried, different ports. My Edge 530 works fine, as well as other peripherals. Yesterday I updated to software version 9.07. Let's hope it helps, or surely it can be a port issue on Explore side.

  • How has this not been resolved yet?! My Garmin is up to date, v10.23, and the Android app is on the latest build and I'm still unable to reliably sync. This appears to be an issue on the app side with activity syncing specifically because messages are instantaneous and weather works just fine.

    EDIT: I just unpaired my Android phone and paired with iOS to test. iOS was able to sync without issue. This verifies that this is an app issue and not a device issue. Garmin, fix your Android app!!!