Live segments

I can't get live segments to work on my Garmin 540. I've ensured Strava is selected on the garmin connect dashboard for segments, and I've starred some in Strava. When I ride a route created in Strava, or in Garmin Connect, it doesn't pick up any live segments. 

When I turn on my garmin, it shows segments in the segment explore screen, but if I go to this when I'm riding, it gives me a permanent wheel of doom. 

Is it me? or is it a bug?

I'm running 9.29 software version. 

  • It’s been driving me bananas. I spent a long time on chat with someone from Garmin support yesterday. He thinks it’s a software fault but can’t quite be sure. There also seems to be a related problem on my Garmin Connect dashboard. When he logged in from his end, he couldn’t see that I had the segment widget enabled even though I had.
    we tried setting segments in there to Garmin instead of Strava. I went on a test ride and the Garmin segments worked fine. I switched it off and on during the ride and they stopped. I went back home and changed GC dashboard to Strava and then it showed Strava segments as I rode. Thought it was sorted. 
    but I went out again today and it’s not working again. Once I got out of the immediate vicinity of my home, the segment explore page went blank and it didn’t detect any Strava starred segments. I’m so cheesed off. 
    im going to be asking for a refund for faulty goods, not as advertised. This kind of buggy product just isn’t good enough. 

  • I see the segments, but have to try it during a ride. Few days ago i saw the segments, but during the ride (after 30min) i cant see the segments any longer. See the spinning wheel..

  • Yup. That’s the same as I’m getting. 

  • Will probably go for a ride tomorow and test it. 

  • So i went for a ride today. Did oress start on a preloaded route, so thats why my segments didnt work, but after i started ride i was the segments. After 20km, theynwere gone.

    Well a friend told me what to try. Did change  the settings in connect app and strava. My settings before were: Strava segments. 

  • As i set segments in connect app to garmin segments, it all started to work. Climb works with no problems

  • That sounds good. Can I check: have you got Strava segments working, or just the Garmin ones? It's the Strava segments that I'm trying to get working. 
    And if you did get Strava segments working, do they still work when you are a little way away from your home?
    What happens if you are 20km away and you go to the Segment Explore page on your Garmin?

  • I switched from Strava segments to Garmin segments in the garmin connect app. I have one more problem to solve: I did check (stared) 30 segments in Strava. This segments should be visable in garmin connect, but i only see 10 from 30 segments. 

    As soon as rain will stop falling i will try if all stared Strava segements are working (as i see only 10). 

    Dont know what hapens after 20km, cause this segments did start from itself (stared in Strava, set to Garmin segments in connect app).

    Try Focusing on Garmin segments

  • Ok, here's more of what I'm learning:

    • Strava segments don't seem to work when I'm doing a workout. Not sure if that's a feature or a bug, but it's annoying either way.
    • My Garmin seems to load Strava segments ok when I set out from home wifi. When I set out from anywhere else, it seems to lose them from the Segment Explore page, but often, not always, notices them when I ride through them
    • Even if I set out with the Segment Explore page working, when I get some distance from home, it then goes blank and gives me a continuously rotating loading wheel.
    • Even though I have Strava segments enabled on app and GC desktop, it still also gives me Garmin segments

    Honestly, this is just so buggy. Wahoo never had these problems. I deeply regret buying a Garmin.

  • So i went for a ride yesterday. I still have Garmin segments set in GC app. I knew where my route would be, so i stared two new segments in Strava, to see what will hapen (i dont see this two segments in GC app). Well it worked. Before the segment started i got a notification and on start i got another notification.

    If your riding your bike on a route with navigation, segments wont work.