Edge 530 not compatible with express

When trying to pair my Edge 530 with Express, I was told it is not compatible.

Do you know how it can be solved?

regards

Parents Reply Children
No Data