G80 picks up club speed but not ball speed which displays as 0.0

G80 picks up club speed but not always ball speed which displays as 0.0.  This started happening a few days ago worked fine before. It  would fail to register a ball speed for 10  shots and occasionally give a spurious clearly incorrect result like 30yds on a full iron hit but registered 0 for most part.  There is no problem with displaying club speed and tempo.

So reset device then it worked ok for a few shot but then problem  reappeared .

Updated device to v4.10 and it worked in fits and starts for a while recording several shot ok and then reverted to problem, seemed to improve when shot path was square to device, but only for a few shots then reverted to problem and stayed that way even after turning device off and back on.

tried device an hour later and it worked fine for 20 or so shots but then problem returned and would not go away even after power off and on.

seems a strange one?

Any ideas as i'm out of them