FIT fields in the mobile app,not in the web page(1.3 DataField app)

I am aware that there are issues with the custom FIT fields but it is mentioned under the 2.x.x section. This is why I am posting this.

I have made a new DataField app that computes three values, which are stored in FIT fields. As explained in the title the values show up in the Connect mobile application while they don't on the web site

Here are the details of the code and screenshots are attached to the post


<strings>
<string id="percent_label">Percent of vVO2Max</string>
<string id="percent_graph_label">Percent of vVO2Max</string>
<string id="percent_units">%</string>

<string id="i_pace_label">Average instant pace</string>
<string id="i_pace_graph_label">Average instant pace</string>
<string id="i_pace_units">min/km</string>

<string id="l_pace_label">Average lap pace</string>
<string id="l_pace_graph_label">Average lap pace</string>
<string id="l_pace_units">min/km</string>

</strings>

<resources>
<fitContributions>
<fitField id="0" displayInActivityLaps="true" sortOrder = "0" precision="2"
dataLabel="@Strings.percent_label" unitLabel="@Strings.percent_units"/>

<fitField id="1" displayInActivityLaps="true" sortOrder = "1"
dataLabel="@Strings.i_pace_label" unitLabel="@Strings.i_pace_units"/>

<fitField id="2" displayInActivityLaps="true" sortOrder = "2"
dataLabel="@Strings.l_pace_label" unitLabel="@Strings.l_pace_units"/>
</fitContributions>
</resources>


const PERCENT_FIELD_ID = 0;
const I_PACE_FIELD_ID = 1;
const L_PACE_FIELD_ID = 2;
percentField = createField("lap_vma_percent", PERCENT_FIELD_ID, FitContributor.DATA_TYPE_FLOAT, { :mesgType=>FitContributor.MESG_TYPE_LAP, :units=>"%" });
percentField.setData(0.0);
i_lapField = createField("i_lap_pace", I_PACE_FIELD_ID, FitContributor.DATA_TYPE_STRING, { :mesgType=>FitContributor.MESG_TYPE_LAP, :units=>"min/km", :count=>10});
i_lapField.setData("00:00");
l_lapField = createField("l_lap_pace", L_PACE_FIELD_ID, FitContributor.DATA_TYPE_STRING, { :mesgType=>FitContributor.MESG_TYPE_LAP, :units=>"min/km", :count=>10});
l_lapField.setData("00:00");
community.garmin.com/.../1442126.png community.garmin.com/.../1442127.png
Parents Reply Children
No Data