Goal time for race events in calendar are not saved.

When I create a new race event in the calendar, there's the option to enter goal time. It used to work fine some time ago, but today I noticed that when I enter a goal time, it is not saved when I save the event. Moreover, when I check some race events I entered in the past, I see that the goal time disappeared as well. Does anyone see the same?

  • Yes. Same for me. Goal time can't be saved and goal times for events in the past are now missing.

  • Yes, I can cofirm it too. It used to work, but stopped recently. It may perhaps still be possible setting up an event incl. the time through the Google Calendar. At least I believe I tested it some time ago, and it worked. Not sure whether it still does.

  • Thanks for confirming.

    Looks like the issue is more global. I just created a course in garmin connect. There's the pace calculator which is supposed to calculate average pace based on goal time for that course, and I used it in the past and it worked ok, but now when I enter a goal time it does not recalculate average pace and does not save the enetered goal time (nor average pace when I recalculate it manually).

  • There's the pace calculator which is supposed to calculate average pace

    Not user friendly, but was able to do it by copying/pasting 0:25:01 into the Goal time text box. Otherwise the time format h:m:s is not automatically input correctly, at last not very easily.

    If I enter 0 in the Goal time then edit over the "00:00:00"  text, I was also able to get it to work. After saving the changes, it seems to be correct. I usually don't use this feature, so not sure if this was easier in the past.