Troubleshooting guide for (some) data missing after syncing

When you find that after syncing, part of the data is still missing in your Garmin Connect Account (for example the heart rate, steps, Intensity Minutes, or Activities), then there are basically the following possibilities. The most common and the most likely reason in most cases is the #4.

  1. First of all, as also in case of most other problems with your device, the first thing to try, is a soft reset (typically - holding the Light button for some 20s, until the device shuts down), or powering down and powering up the device. It often fixes weird behavior, especially after firmware updates.

  2. Your Privacy Settings do not allow sending data to the Garmin Account (verify the option Storage & Processing), or the device is not set as the Preferred Activity Tracker (check out the Device Settings on the Garmin Connect Mobile app » Activity Tracking » Preferred Activity Tracker)

  3. The BT synchronization on the phone app does not work (the white circle around the watch symbol never closes) - in that case follow the tips in the Sync / Connection Troubleshooting Guide. Alternatively, you can sync the data with the GC account over the USB cable and Garmin Express on a computer, or manually by importing files from the device folder //GARMIN/ACTIVTY/ to the Import Data page of GC Web (in case of errors during the import, see the hint #4). On Android devices you can (and you should) also review the Device Sync Audit (in GCM Menu » Settings), and browse though the last audit reports looking for errors and warnings.

  4. When the synchronization works (the white sync circle closes and turns green), but not all the data is appearing in your account, then it very probably means that there is problems with the association of your device to the GC account. Again, try restarting the watch (if you did not just do it), and shutting down the GC Mobile app (iOS: swipe it up in the iOS App Switcher; Android: Android Settings » Apps » Connect » Force to Stop), and then restarting it. If it does not help, remove the device from Garmin Connect, and then add it back again. If it does not help do all these steps:

    1. Remove the watch from the Garmin Connect Mobile app
    2. Sign out of the GCM app!
    3. Remove the watch from the list of Bluetooth devices on your phone (Android or iOS system settings » Bluetooth !
    4. Remove the watch from the Garmin Express on the computer
    5. Sign out of GE!
    6. Remove the watch from the Garmin Connect Web
    7. Sign out of the web account!
    8. Sign in back to your original Garmin Connect account on the app, and add the watch again. Repeat with Garmin Express.

    Please note that this operation will not bring back the lost data, but it prevents that it continues to happen!

  5.  When it does not help, perform the Master Reset of the watch/device - it will have similar effect, but you will need to redo some configuration and customization of the device.

  6. The storage (or a FIT file storing the Activity details or HR data and the steps data) is damaged or full. Try backing up and deleting old files from the folder //GARMIN/Activity and //GARMIN/Monitor. Look up the last unsynced activities from the folder //GARMIN/Activity, and try importing them manually on the Import Data page of GC Web. If you get errors when trying to import them, try fixing the broken files by passing them through the Section Remover of FIT File Tools (without removing anything), and then importing again the repaired file(s).

  7. If you own a second-hand device, or a device from not a well known online reseller, there is a chance it is a stolen, or a counterfeit device. Garmin continuously removes any such devices with known S/N from their database, disabling so their syncing to your Garmin Connect account. If you suspect it could be your case, contact the Product Support, ask them to verify the serial number of your device, and if not found in their database, or when being on the blacklist, contact the seller and request a refund. See an example of such case in the thread Help with data not updating after sync
  • Hello,

    I have an issue with my Garmin Forerunner 35 and my Garmin Connect App.

    When I record an activity and save, it automatically syncs to the Connect App and tells me that I can view it. But afterwards when I look in My Activities - All Activities, it does not appear there. It was working fine up until about 2 weeks ago.

    I have tried all of the recommended troubleshooting steps:

    - rebooted watch and phone

    - did a software update

    - disconnected and reconnected

    - removed watch from Garmin Connect and readded

    - removed the paired device and reconnected in my phone's Bluetooth settings

    - tried syncing using Express. (Same issue - it tells me that it has fully synced and there are no issues but my latest activities do not appear in All Activities log

    The weird thing is I can see my Activities saved on my actual watch. The sync appears to work successfully (I also checked the Device Sync audit on the Connect app, and there are no errors being thrown). The little sync incon in my Connect app is green, and manual sync works ok.

    But activities are still not being pushed successfully to the Activities log on my Connect app.

    Is there anything else I can try? The only thing I can think of that happened recently was that I allowed my watch battery to die whilst on holidays. Since then, after charging up - the Connect app has failed to pick up my activities properly.

  • It's not clear to me whether or not you removed the watch from the Connect Mobile app, the Connect web application, and Garmin Express, and then added it back to all three again. If you didn't do all of that I would try it as per the troubleshooting guide. If you did, then my apologies for not understanding and maybe someone smarter than me will be able to help you.

  • When I record an activity and save, it automatically syncs to the Connect App and tells me that I can view it. But afterwards when I look in My Activities - All Activities, it does not appear there.

    There is indeed a recent bug in the GC Mobile app. It prevents nameless activities to appear on the My Day screen. However the data is not missing. It is there and you can access it a number of ways: GC Mobile menu » Activities, or GC Mobile menu » News Feed, or GC Mobile menu » Calendar, or GC Web » Activities. You can also avoid the issue by selecting any other option than "untitled" in GCW User Settings at 

  • Weirdly it has just started working again. I'm not even sure how to be honest. I went for a short walk yesterday evening and when I stopped and saved the activity on my watch it suddenly started to appear on my Connect app and Strava again. 

  • Not missing data, but.......I'm updating my maps now and Why is the DL speed so slow ??   511KB/s !   I have fiber and it's 450 mb/s

  • Except when it's none of those and 4 hours over 3 days with technical support is no help, making $3000 worth of Garmin products useless for training purposes.

  • You're still here? Grinning

    Back to the Casio Multiband 6
  • Disappointed that I lost all my steps from one day.

  • I would like to add that it could be your watch has the wrong date. I hadn't used my watch in a while and when I started using it again, I had this problem where my watch and app would say they synced but no data was showing up for the day. Turns out it was syncing, just showing up in 2017 on my calendar! I fixed this be doing master reset on my watch and then re-connecting it to my app.

  • I've tried all of the above and I'm still missing my HRV status, heart rate, body battery and steps since midday yesterday...despite me being able to see them on my watch. How can I push these through manually? Can I access a file somewhere in my watch (via PC) and dump it on Connect somewhere? So painful. My sleep showed up though. Any suggestions?