This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Garmin Connect app broken for Android tablets. Watch won't pair with the 4.75 release

Is the app broken for Android tablets? My watch won't pair with the 4.75 release of the app. Last successful sync was with 4.74.1

I do see the other posts in a related thread and can also see the complaints on the play store that indicate others are having the exact same problem. So I know I am not raising something new here.

But I was just on a chat with support and they said there is no known issue related to tablets. I would liked to know if Garmin is saying that the current version of the app does work with Android tablets (suggesting that I have some hardware problem) or if there is a fix coming. Does anyone have any info here?


  • Thanks all for the replies. So far I haven't seen anyone post "I have successfully used my android tablet with the 4.75 release." Everyone is saying they either are stuck now with a broken app or they had to switch to an older version of the app to get it to work again.

    Did anyone have a different experience with their Android tablet? Did it just keep working with no trouble after the new release?

  • Same problem with Garmin 935 and Connect app loaded via Play Store on Amazon Fire tablet. Doubt Garmin will support that, but it was working fine until the last update.

  • I have the identical issue to earlier commenter - 4.75 works on Android phone, but not on Android tablet 

  • My Forerunner 55 stopped syncing on an android tablet a few days ago and I went through the re-pairing process without success. I tried another tablet and it also failed then I used an android phone and it paired and synced without any problem.

  • Your phone may have the older version of Connect. I got out my old tablet with 4.7 and it connected. Just tried on my Galaxy Tab s6 but no go.

  • Did anyone have a different experience with their Android tablet?

    I installed GC 4.75 on my wife's Galaxy Tab S7, running android 13 and could not get my epix (Gen 2) to connect. Works fine on my Galaxy S9+ phone. So suggest anyone with this issue should contact Garmin Product Support (or contact them again). There is something wrong with GC on tablets. Send support a link to this forum thread to at least give them a heads up.

    If you're stuck and have no other mobile device to sync, you should still be able to sync using a Windows or Mac computer running Garmin Express until this gets ironed out.

  • All the phones and tablets are running 4.75, but different versions of android so it may be some versioning issue with android/BT or perhaps lack of a cellular transceiver extensions, but in any case it seems to be very much a GC software issue.

  • GC works on my older Galaxy S3 with 4.7 but my S6 running 4.75 will not sync with my Fenix 3 HR.

    Have Garmin admitted a problem? I can't find any info. 

  • That's interesting. So it's an architecture problem (if I can put it like that) rather than an OS release issue. Connect 4.75 doesn't like tablets! 

  • I'm not sure. My friend has a Samsung Galaxy phone and it quit working.