Spotify CIQ App not working correctly

We are investigating reports that the Spotify CIQ App not working correctly and we are wanting your feedback. Please provide some details about what is occurring when you try to use or setup the Spotify Connect IQ App. Below are just a few questions we would like answered.

  • What is happening? (e.g. failing during setup, sync failure, playback failure, etc.)
  • What kind of phone are you using?
  • What kind of headphones are you using?
  • What Garmin Device do you have?
  • When was the last time Spotify worked correctly?
  • Does the problem only happen with a specific Audio File?
  • Are you using Public WiFi? (Using a Wi-Fi Device on a Captive Portal)
  • What software version is on your Device?
  • Do you have a vivoactive 4 (Hero Series or Saga Series) device? 
  • Pixel 4. Vivoactive 3 music. Not sure how long ago it worked correctly. Happens with all audio files.

  • Samsung Galaxy S7 Edge. Vivoactive 3 music, Spotify last worked correctly Tuesday 24 February then the following day wouldn't work. The problem happened regardless of music or podcast. I tried turning the watch off and on. It has previously happened but then the audio started working during my workout. On this occasion when I selected the audio and it went back to the play screen the track didn't appear.

  • Spotify either fails to sync from playlists (syncing failed message), or syncing stays at 0% indefinitely and does not complete even for a single song.

    Nokia 8.

    Headphones are irrelevant since the app just cannot sync.

    Vivoactive 3 Music.

    Brand new device, so this was the first (although multiple) attempt to sync with Spotify.

    No specific file, tried different playlists or single songs

    No, i'm using my secure home wifi with the watch positioned right next to the router.

  • - Does this change if you plug the watch into a power source? How long did you wait for the syncing to complete?

  • Plugging in a power source does not change anything.

    I've either got the "syncing failed" error within 30 seconds of starting it, or it stays at 0%, I've left it for periods of up to 40 minutes to sync just a single song, and it's at 0% all the time. 

    Attaching image

  • Disregard please, finally managed to make it work by connecting to a hotspot from my phone instead of the home wifi, for some reason that was not working.

  • Vivoactive 4 and Pixel 2XL. New watch with v4 software. Single playlist with 200 songs selected to sync. Sync starts ok, connected to WiFi, proceeds for a number of percent (less than 10%) and then hangs. Eventually I get a sync failed message. If I restart the sync it will quickly figure out where it got to and continue from that point, for another 7% or so. In this way after 15 or so syncs the whole playlist is transferred. To me this looks like the watch is dropping the connection, which suggests either the WiFi connection or the Spotify connection. Hope this helps, and hope you have a fix ready soon! 

    • What is happening?  Wifi is not syncing. Will not let me download playlists and gives me error code 0104. I have only gotten it to work once while hotspotting from my phone.
    • What kind of phone are you using? Google pixel 3XL
    • What kind of headphones are you using? Have not even hooked headphones up yet 
    • What Garmin Device do you have? Forerunner 945
    • When was the last time Spotify worked correctly? Have not even used it once yet. Only have been able to download a few songs 
    • Does the problem only happen with a specific Audio File? No
    • Are you using Public WiFi? (Using a Wi-Fi Device on a Captive Portal) no it will not hook up with even my secure home wifi with a WPA2 password 

    Please note my partner has a Fenix 6X and he has no issues using our wifi network. 

  • I'm getting this problem too on a 645m. It fails at a % through syncing music updates. I also get a separate error of incorrect WiFi password on updating individual podcasts. This happens repeatably on alternate download attempts so it doesn't actually stop downloads.

    My phone is a Huawei p20 pro and I have Aftershokz Aeropex headphones. A further bug is that these occasionally disconnect, which seems to be brought on by electromagnetic interference, eg when running under a railway line.

    I've no idea which audio file causes the problem. How would we know? 

    I'm using my own WiFi with a Virgin Superhub 3.

    Finally, the Spotify app needs a lot of work not just on bugs IMHO. It's very clunky to use especially for podcasts, which take a long time to sync and can't be done in a batch but individually. There needs to be a better way of doing this from the phone app, rather than the app, which may also help to solve the bugs. 

  • I have a Vivoactive 4s (purchased in January 20) and Samsung Galaxy 7 edge. Using private Wi-Fi at home. I cannot setup Spotify on my watch. When I follow the steps and log in to Spotify through the Garmin connect app, I get the message " Sign in complete. Return to your Garmin Device". I do not get the " Get started " message on my watch. Help please!