Garmin express says I have 2021, drivesmart shows 2019

Just receivedy drivesmart 61 and BC40 direct from Garmin. Love the GPS, backup camera was a breeze, voice commands work fantastic.

I hooked up the drivesmart 61 to my PC(actually 2 different ones) as I did with my Zumo 395 and 396. GE launched and wanted to update the unit. I already know the unit had 2019 maps installed. To my surprise, GE said it'd take a couple of minutes to update the unit.

It showed 6 updates. After it was finished, it said my drivesmart was up to date, said it had the 2021 maps.

Disconnect drivesmart, turn on and it does it's little green bar updating several times. When it's done, I view 'mymaps' on the device and it's still showing 2019 for CN Garmin, Foursquare and one other source I don't recall.

Hooked it back to PC, GE launches and says it's current, says 2021 map on unit.

I launch basecamp, basecamp shows the unit has 2019(which is what the drivesmart says it has)

What gives?

I tried a second PC, same results. I connected to my  wifi and the drivesmart says there's a new map to download and update. I tried that(as I did with my Zumo 396), and it failed to finish downloading.

How do I get GE to realize the GPS doesn't have 2021 maps on it?