Basecamp 4.7.1 and Generic Routable (new style) for Garmin

I installed BaseCAmp 4.7.1 this morning over the previous version that was installed a few day ago on a fresh Win 10 computer which worked well. Subsequently I installed the OSM Generic Routable (new style) for Gramin Texas maps.  

Basecamp opens and displayed the OSM map for about 5 minutes then threw up an "Error Detected" box and closed. 

I have uninstalled and reinstalled Basecamp and removed the OSM maps from the drive. Basecamp still gives an error message and closes.

Any ideas on restoring Basecamp? Has anyone else tried the OSM maps on 4.7.1?

Error report

App: BaseCamp
At: 11/5/2019 8:46:46 AM (UTC-6)
OS: Windows 10 (64-bit)
Processor: x86, Processor Level: 6, Processors:4, Model: 60 Stepping: 3, RAM: 25115836

External component has thrown an exception.
at System.Threading.ThreadPoolWorkQueue.SparseArray`1.Add(T e)
at System.Threading.ThreadPoolWorkQueueThreadLocals..ctor(ThreadPoolWorkQueue tpq)
at System.Threading.ThreadPoolWorkQueue.EnsureCurrentThreadHasQueue()
at System.Threading.ThreadPoolWorkQueue.Dispatch()
at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()

Active Map Product:

Installed Map Products:

Map Name: Global Map (Garmin Product)
Map Id: 133758977
Map Version: 2.0
Map Type: Bundle
Custom Drawn Map: No
Digital Elevation Model: No

.NET Versions:
.NET FW 1.0 not installed.
.NET FW 1.1 not installed.
.NET FW 2.0 with SP2 installed
.NET FW 3.0 with SP2 installed
.NET FW 3.5 with SP1 installed

Attached File: MiniDump