This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Connected GPS issues

Former Member
Former Member

Since May 2nd I don't get a map or only a partial map after saving a connected GPS activity. I haven't changed anything in my settings and I always wait until the watch announces GPS ready. Anybody else experiencing this issue?

BTW: I use an iPhone XS with latest iOS and latest GCM app.

  • I tried to connect bluetooth headphone and play music during the trip tracking because be sure that bluetooth is not impacted by phone battery management. But without any effect. Still same problem. Only a few meter of trip in map. I used samsung A7 2017. If I use Huawey P20 pro it wokrs coretly.

  • Hello,

    facing the same issue as you are desribing. Samsung A40. Vivomuve3 Luxe. As per my observations:

    Phone GPS is connected correctly however after few minutes of activity, seems that GPS connection lost.

    a) if am not touching phone during the activity (still locked) and not touching the watches - the track is not iniciated anymore

    b) if am am touching phone and/or watches the track (GPS) is initiated again for while

    - so my suspection is:

    a) when the phone starts to "hiberante" or some save mode is initiated in the phone after while (but this is not connected with display lock) - GPS connection lost with watches. And seems that can be estabilished again when I unlock the phone or/and "touch" the watches

    b) or mayby (i have no proof) - when there is lost of signal lost of GPS signal by the phone for while (can happen) - whole GPS connection between phone and watches is closed....

    However this is quite sirious problem what makes me unhappy with this watches and Garmin should take attention on this (some patch)...

    When I run in parrallel other sport tracking application (Sporttracker e.g.), ther is full track of my activity, even if I have phone in pocket or in my hands - there is no difference.

  • Today, I tried to play with phone setting and now get full GPS track. Samsung A40, Android 10. 

    Mayby the problem lied here in phone settings:

    I went to settings-->Apps--> top right aditionl options (3dots) --> Special acces-->

    I set foolowing otions for Garmin connect app:

    a) Optimize battery ussage - off

    b) Appear on top - on

    c) Change system setting - on

    d) nottification access - on

    e) Allow app while Data saver on - on

    d) Wi-fi control - allowed

    now worked well. will observe if solved the issue....

  • Hey Sal,

    Sorry the delay. Just wanted to say that you don't forget to search the system apps related with Bluetooth in the battery management. With me it was not enough to set the GC in "no optimized".

    Hopefully you found a work around.

  • I still have this gps issue Garmin- my iPhone 8plus and Garmin app are up-to-date- this is bloody annoying!! I want my gps tracking to work. Who can help me out?!