Brand new Garmin S2 not connecting to network even when network name and security is entered

This has been a bit maddening. My brand new Garmin scale (first time I have had a Garmin) will not connect to my network/wifi no matter what I try. My network doesn't even pop up on the Garmin smartphone app so I have followed the instructions for entering the network name manually along with the type of security. I have tried locating the scale near the router, a little further away and even further away - still no connection. I had a pretty good thing going with my FitBit watch and Aria scale but was looking forward to more from the Garmin ecosystem. The scale itself states it needs a software update so I have followed those reset instructions too but it can't do a s/w update if it can't connect to my network so I am stuck in this circular problem. I've sifted through the Q&As, looked at this forum but can't see a solution that applies. Please help! I finally got myself psyched up to step in but this has taken all the fun out of it so far.