Index Smart Scale stuck at wrench and blinking wifi icon

My nicely working scale since many years started to act up not uploading data. Realized it was not finding the WIFI. I have tried to reset it an connect it again but I am completly stuck at the wrench and a blinking wifi-icon. The 5 second reset does not do a reset at all. All I get is the wrench and the WIFI-icon.

I have tried to log out from the app after removing the device from the account.

I have made sure any other wifi-networks close by are turned off and bluetooth devices close by also turned off

I have tried to remove the batteries for several minutes and then do a reset

I can use the scale for taking a measurament of weight but i returns to the wrench and wifi-icon not displaying anything else. 

The scale does not turn of so I need to remove the batteries for it shut down.

I have searched this forum and others for similar issues but found nothing. 

I put in new batteries twice

When doing a reset once i cannot do a reset again if not first removing the batteries 

Any suggestions?