This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

"Wrench of Death" - how I solved it on iPhone

Issue: Index Scale persistently stuck on setup screen with only the Bluetooth icon solid lit. The KB article 'My Index Scale Is Showing and Wrench and Bluetooth Icon' did not help.

Solution that worked for me on iPhone:

  1. Log out of Garmin connect app;
  2. Uninstall Garmin connect app from iPhone;
  3. optional: soft-reset iPhone;
  4. optional: Reset Network Settings on iPhone (after that re-configure WLAN on the iPhone to prepare for the next steps);
  5. Log in to Garmin connect, remove the Index Smart Scale from personal account;
  6. Ensure that the scale is running on fresh 1.5V (non-rechargeable) batteries;
  7. Reset the Index Smart Scale, using the reset button on the back;
  8. re-install Garmin connect app on iPhone and log in;
  9. Add the Index Smart Scale as a new device, as described in the the Garmin Manual;
  10. Bluetooth setup should now proceed and find the scale. After Bluetooth setup is complete, the Garmin connect App gets stuck on the "Wi-Fi Network" screen with the "running man" icon. Wait a 1-2 minutes to ensure that the issue does not resolve by itself.
  11. If setup does not continue, Cancel the "Wi-Fi Network" screen within the connect App; it will say that setup is not complete (which is accepted for now);
  12. With the Index Smart Scale still being stuck with its "Wrench Screen", quickly log out of the Garmin connect App and terminate it
  13. Re-open the Garmin connect App and log in again; skip over adding any more devices
  14. Quickly go to the menu "Garmin Devices" instead and, hopefully, the Index Smart Scale is visible, showing a red exclamation mark which indicates that the previous setup was incomplete
  15. Tap on the scale in the connect app and it should now continue with the setup showing WiFi networks. From there, the configuration can be finished by entering the WiFi password (ensure that the Scale is not turning off during the entire process!
  16. Finally the Scale should reboot and show a checkmark and a WiFi symbol. On the phone, the exclamation mark should be gone too. That indicates that the scale is now paired with both, Bluetooth and WiFi and will hopefully will receive a firmware update that fixes this issue ;-)