This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Index Scale won't connect with Garmin App


I have had this scale for years.. All of a sudden it is no longer connected to the Garmin app. App says it's connected but scale does not recognize myself or my wife. WIFI Icon is off no change to password or router.. So I went into app selected the device and they are not communicating any longer.. I did put the scale on the wrench when trying to communicate.. I changed the batteries nothing.. So I uninstalled the app and started fresh by setting up my devices.. App still can't connect to the scale. Wrench is on and the app states "Setting up device" but the details is showing me that it keeps timing out while connecting to the device. 

Not sure what to do next. 

  • Same here ! Could you solve this ?

  • Hello! Could you please reset the scale then try to add the device back to the app?

  • This same issue is happening with my index scale.  After the reset it connects to Bluetooth but the connect app gives me “Device Not Found” after trying to “Add Device”.  I’m using an iPhone 13 with the latest connect app.  I’ve also tried pulling the batteries for over 10 minutes with still no luck.  Any ideas that I can use to resolve this?

  • I'm having the same issue. The scale is in wrench mode but the app says Device Not Found.  When I go into Bluetooth setting on my iphone 13 it shows connected.  Please help!

  • I’m still waiting for a reply

  • Ok, the problem with the iphone is that once you pair with the scale it gets paired even if you make the reset. I finally gave up and use my iPhone hotspot to get the scale into my wifi.

  • I finally got mine to work.  I took another phone and signed in with a different connect account.  While pairing it told me it was connected to another account and asked me to reset it.  I reset it and then stopped the process on that phone.  I think grabbed my phone with my connect account.  I restarted the process and it once again asked me to reset the scale since it was attached to another account.  I could never get to this point before.  After resetting I was able to continue on setting up my user.  It is now working!

  • That's great! finally you got successful.

  • Thanks so much for your solution. Worked for me as well :)

  • If you don't have another iPhone (I don't know if this problem is exclusive to iPhones but that is what I was using) with a unique Garmin Connect account - you can create a dummy Garmin Connect account. Log out of your primary account on your phone, log into the dummy account, and connect the Index scale to your dummy account. As mentioned in the previous post, cancel the process once you get the notification that the pairing is complete with your dummy account. Log out of your dummy account and log in with your primary account. I was able to sync with my primary account after doing this...Good luck!