This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Garmin Index Scale Wifi Connection Fail - Resolution

Regarding the much discussed but rarely solved problem of failing to connect a Garmin Index Scale via WIFI: I have Garmin Index Scale which was happily connected and working properly on a Router A.  Then I changed routers to Router B and the scale refused to connect via WIFI and upload data.  Actually I went through the process of connecting the scale via the mobile app, then would use the scale, the wifi icon would blink continuously and the data would never upload to my account.  I tried reseting, factory reseting, fiddling the modem settings, verified I was using WPA/WPA2, used the same password as on the working setup.

Then I tried shortening the network name to 10 characters.  That shorter network name was all that was needed and now the scale connects correctly.  I find it rather shocking that Garmin has nothing on their website support section about character count limitations or whether special characters are allowed in the network name or password.  This would be very easy for them to do and clearly their software does have a serious and not obvious limitation here.

  • They needed 1.5 years to get their NTP call, wich was working pretty bad, fixed. I believe they switched from an unreliable in-house server (this is a fact) to a reliable public one.

  • Funnily enough I never had a problem UNTIL they changed the NTP server!  Since then it has never connected!

  • My scale is also only blinking. It worked before. Now i have a new Modem with the same Wi-Fi name (the Scale uplaoded data before)

    but now i have the blinking of death with the same Wi-Fi Network Name. So that didnt helped me =/

  • Incredibly I just did my 'three monthly have they got it working yet' and I find my Index is now connecting successfully to my network!  Yeehah!

  • Thanks for the tip! Worked wonders!

    I had the exact same experience and had to "RMA" my Garmin Index twice before I found your post, shortened my SSID to 9 characters and there you go: all solved!

    Thanks again for sharing!

  • I have a 4 letter Router name and a a 6 letter router name. It connects to none.... That was perhaps luck, but it does NOT work & I am sending it back to the seller.

  • I had the same issue till today. After a tcpdump i saw that the scale constantly was doing a dns lookup for I have nextdns in place (cloud pihole idea) i disabled that and BOOM it started to work again

  • Also tried changing name down to 8 char all capital but no success.

    Does not connect with WPS or  WPA2/Password.

    This router is from Vodafone provider.

    Connecting to a FRITZ!Box 6490 Cablerouter works although name has 14 characters.

    So seems to be hardware related issue.

    Must omit that it is a poor behaviour of Garmin support that they do not put some light on this Problem with their device :-(

  • I'm unsure if you aren't understanding, or are using incorrect terms.

    The name(brand) of the router is not important.  It's the length of characters (spaces included) of your wifi network name (SSID).  I setup a guest network specifically for the scale to use, made an 8 character ssid and it connected immediately. 

  • I think the point is that most of the default SSIDs have the brand name in the SSID, and that they had no issue connecting to that SSID.

    Any input from Garmin on this would be helpful.