This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

WiFi and Connection issues for the Tech Dummy

My scale does not connect to WiFi and does not send data to GC. It did seamlessly a few months ago, but then all of a sudden it pretty much stopped working and hasn't worked since.

So much chatter on this forum of what is causing the problem and some viable solutions.

The problem is, I am not tech savvy and I do not understand most of the chatter that is going on.

What I would like is:
- Garmin can fix this problem on their side so that ALL USERS will not have this problem anymore.
- send out a STEP by STEP set of instructions that a dummy can understand on how to set your router or what I need to do to fix the problem.

  • I received my replacement Garmin scale today. It looks like they sent me a brand new one since it came in a retail box including, instructions, new batteries and rug mounts. I inserted the batteries, and deleted the old scale in Garmin Connect. Used Garmin Express via Ant+ to set up the scale using my local Wifi. The setup completed with a BIG Tick on the scale. Stood on the scale and the data instantly appeared in Garmin Connect after a page refresh. It couldn't have been easier. Therefore my connection problem was due to a hardware fault in the scale. Since I have owned the original scale since Christmas 2016, and it work flawlessly until now, I suspect the issue may have been humidity in the bathroom which could have led to oxidation and corrosion of the internal components. Electronics and water don't mix well. In fact they don't mix at all. And according to Joachim1234, he was able to resolve his issue by moving the scale from the bathroom to the bedroom.

    I had the exact same issue, but I have seem to fixed mine.

    I started by resetting the scale, choosing activity level 5 and moving my scale from my bathroom to my livingroom.
    To begin with the scale still showed BF 7%, but after two hours it showed 12.1%.

    My guess is that the scale can't handle the humidity in my bathroom, so now I keep the scale in my bedroom.

    We also kept the scale under the vanity and would pull it out and push it back in a number of times per day for each user. The bumping and jarring may have also been an issue. I don't really know since Garmin Support didn't provide an explanation as to the cause of the failure.

    Richchin_tw, since you seem to have the same symptoms, your scale may have a hardware problem. If possible, contact Garmin Support. They replaced my scale for free (I had to pay $10.50 AUD to ship the old scale back to them). If you keep it in the bathroom maybe humidity is a factor . You indicated that the scale worked seamlessly; then stopped. Try moving it to another room and see if that improves connectivity over a number of days as the unit drys out. Try the reverse polarity trick and phone test as I suggested above. And another idea would be to take the scale to a friends house and connect it via their Wifi. Do you have the same issue?
  • A simple change to your router settings would be to lock your channel width to 20 Mhz. Mine is currently set to Auto with no issue but there is a 40Mhz and 20Mhz option.

    After som heavy investigation I found out that the firmware v. 3.0 does not handle 40Mhz channelwidth on 2.4Ghz correctly. So once I configured my WiFi Accesspoint to use 20Mhz only (No channel bonding) my Index scale started connecting correctly. I also had to use the DNS trick with to get it to connect every time.

  • And you can try changing your wifi channel

    I bought the Garmin Index Scale recently and I experienced the same issues as everyone has stated regarding the WiFi connection. This is total pain and there is no documentation on this.

    After some trouble shooting here's what I gathered and it has proven to work for me.

    The scale's WiFi is US based 2.4GHz, i.e. it will connect on channels 1 to 11 only. If you have set your 2.4GHz WiFi channel to "Auto" and your router's region has been set to UK or Asia, your router could have very well picked 13 as it is least used, this is true for my case, when this happens the scale will not connect to your WiFi.

    To ensure that the scale will connect every time:
    1: Set your 2.4GHz WiFi channel to manual and select from between 1 to 11. If you must set it to "Auto" to allow your router to auto switch to a less congested channel, then you have to change your router's' region to US, which will limit it to channel 1 to 11.
    2. For the wireless security, configure it to use WPA2 instead of mixed mode, the scale seems to have some issues if you have mixed mode turned on.

  • But channels under 9 may be best;

    I'm using a FritzBox and it is working fine

    But I noticed that some Garmin devices have problems with WLAN channels > 9
    Try to setup your WLAN Channels less than 9

  • And as I mentioned before, I use a TP Link Router

    I solved this issue

    I send my scales to support, they send me back with resolution that everything works well, they tested it for few days. At home the connection issue was still active, no SYNC with Garmin connect.

    I found at home one old TPLINK wifi router about 8-10 years old, configured by default WiFi - just for my INDEX scales and its working already one week without any disturbances !

  • Even though I get the big X and it behaves as if it didn’t work, it still works and eventually my stats are uploaded. I haven’t touched any setting since and so far up until now it is still working. I am taking your advice and just not touching it for now or making any changes to any settings.
  • In a previous post you mention other members of your family use the scale. Perhaps the following is your issue/solution.

    We understand that there are many users who have added additional users to their Index Scale, only to find that these users are unable to sync. This issue has been escalated and an internal ticket is currently being worked.

    We have found that in many instances, the added users have not consented to data uploads (a change that was made as a result of GDPR) which is preventing uploads and resulting in the X icon on the display. If you are experiencing this we would recommend the below troubleshooting steps.

    1. Have these users ensure they have consented by going to this link and selecting Data and Privacy
    • This can also be done by signing into the account from Garmin Connect Mobile

    2. Delete the invitation to these users and add them again (after ensuring they have consented to data upload)

    If you are still seeing this symptom please respond to this post with a detailed description of what you are seeing. We are also looking into why the original owner of the scale is seeing the X icon but still uploading data. Thank you for your patience and cooperation.

  • Hi everyone,

    With much excitement I received my Index earlier this week, only to have encountered the same issues you’ve all been experiencing. I can’t access the settings on my Virgin Home Hub 3.0 to redirect to a reliable clock and given the expense and supposed reliability of the Garmin name really don’t think I should have to. I have tried the solution offered above by Garmin and this has not worked.

    Please advise us on the progress of a fix or other workaround, Garmin. Thank you!
  • Just a follow on update from my post #18. I had upgraded DD-WRT on my router a couple of weeks ago so removed the NTP fix since I didn't really need it - based on the fact that I had rarely seen an issue with connecting prior to implementing the fix anyway. Note: I am on Google Fiber, have 3 x Netgear R7000 with DD-WRT installed.

    However this morning the scales would not connect and upload. Tried 5 times within success, went to my router and applied my fix as mentioned in post #18, then went back and stood on scales and they connected and uploaded. Total elapsed time from first failed attempt to the successful 6th attempt was < 5 minutes. Not conclusive proof, but I will keep the fix applied and monitor.

    For anyone else experiencing this issue then the concept of the fix is to try and have the scales connect to a different 'time server' than, where it seems to time out and fail to connect. You can do this by having your router provide the scales with a different IP address than for by overriding this look up address.


  • I have a DIR-880L router. Can anyone advise me on how to update the NTP fix? Thanks!