WiFi Password Not Being Accepted During Set-Up

My Garmin Index Scale will not connect to my home Wifi network.

During set-up the Garmin connect app prompts me to enter the WPA2 password, which I am definitely entering correctly. It then says the the password is incorrect!?!?

I am using the Virgin Media Hub 3.0.

Can anyone help me please!?

Thanks so much.
  • How do I remove the wifi password?  I am trying to use my mobile hotspot and NO password works Any help?

  • I have been running this in circles for a month, now.  I bought my Index in November, and it set up and worked on my secured network just fine until early March.  Took almost a week for me to figure it wasn't sync'ing to my account anymore.  I get a wrench and the WiFi icon with 2 bars lit and the third flashing.  While the "old" network was present, I couldn't get the scale to a screen where I could change anything.  Worked thru Garmin tech support, and ended up getting a replacement scale.  Just tried to get it started and I get the same exact thing!

    I rename my normal network so that I can force the scale back to "3 radios" icon and connect bluetooth from my phone.  I put out a guest WiFi with no password, and scale appears to link.  I can query the list of devices the router is managing, and there's the scale.  After about 3-5 minutes, it disappears from the router list.  (I have to manually refresh the list, so I'm not sure exactly how long for it to disappear.)  I can never see it as a device on the router when I'm using the secured network.  The scale continues to show the wrench and WiFi icons, and never gets to a point where I can use it.  

  • UPDATE. It's now six months later and I could not find a way of resolving the above. Garmin's position was basically that as my scales worked with my previous ISP company and still connected to an ISP in a friend's flat, but not my own then it must be something for the ISP to sort out. My ISP provider were very helpful but could not fix the problem either. They created a new channel with a simple password for me. We tried on 2.4Ghz and 5GHz but to no avail. As the scales were a third part device, they said they could not help further.

    BUT, I am pleased to say my scales now do work, but alas with a fix you might not be willing to go for. Separate to all of this I needed to get a Wifi booster in my flat. I bought Google Nest Wifi plugged it into my existing router and hey presto the scales and Garmin work perfectly again.

  • I've also seen a similar issue in the past - an install of Pop_OS! refusing to connect to a WiFi access point when all other devices have no issues. That issue persisted even when I removed the WiFi password. I never found a solution unfortunately! shareit

  • Fixed this issue on my Tactix Delta Solar by switching my router's 2.4 GHz channel to use Legacy Mode versus Compatibility Mode.  I have a Verizon G3100 router so not sure if others have this option on yours.  So...seems to be issue with 2.4 GHz wireless protocol or version.

  • My girlfriend's Vivo Active 4S could not connect to my Deco M5 network, both 2.4 and 5 ghz wpa-PSK (AES) security. So I tried connecting it to the wifi of my modem (which I don't use normally), it has the 2.4 and 5 ghz and also wpa-PSK (AES), and there it could connect. My Garmin 245 Forerunner did not have any issues connecting to the Deco network.

  • Garmin's programmers are not very good.  What I think it happening to you has happened to me.

    Their watches have a maximum Wifi password size of 32 characters.  The problem (bug) is the watch will let you enter a larger password.  The result is a connection failure error.  Obviously it's not a connection failure.  It's an invalid password despite your entering the correct password.  I think they are just cutting off whatever you enter at 32 characters.  They are forcing us to dumb down our networks to their standards.  Even proper error reporting would have given us the clues required to deal with this.  They can't even do that.

    My solution is to create a new Wifi network for dumb devices that has a short password.

    My Garmin devices can now connect.

  • I was having the same problem and I fixed it! Also, I apologize but I don't know all of the lingo. For reference, I have a Vivoactive 4 and I use an Arris surfboard router.

    Here's what I figured out.  First, I believe it has to be connected to a 2.4 wifi thing.  My router has both a 2.4 and a 5. For whatever reason, I can't EVER connect to the 2.4 one on my phone so I always stay connected to the 5... And I assume the 2.4 does not work for whatever reason. When I tried connecting to the 2.4 on the Garmin app, it said incorrect password (which it was not).

    I went into my wifi configuration/routers settings on my phone and added a GUEST 2.4 connection. Then, I went back to Garmin connect and the new connection came up (as well as the original 2.4 connection). I clicked on the new one, entered the password that I had set, AND IT CONNECTED! Hope that helps. 

  • I know this query is old, but I've just had exactly this issue. Discovered the Garmin Scale did not like my BT Wholehome mesh network extender. I just connected it direct to my router wifi and it works. So Garmin seems to have tech issues with wifi range extenders. Mine now works, but I need to have the scales within range of the router in my hallway. ;-(

    anyway, hope this helps somebody