This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

0.0 flashing on screen

Just got the new scale....
After a lot of trouble and 70min on phone with Garmin, we finally managed to set it up and scale shows up in Express and in Connect.

But now........when I step on it I get 0.0 kg on screen. This is on there for 5 sec, and then dissapears for 5 sec...and just repeats the loop....until it goes to sleep.
I stand on the scale, with no effect...the loop just continues.

Did anyone have an issue like this?

  • Please excuse me if I am misunderstanding your question, but here's how it works for me. Before I stand on the scale, I need to tap on the surface with foot until scale "wakes up" and displays 0.0, then step on to weigh.

    Sorry if this is too fundamental but thought it might be worth a shot. Hope you get it figured out.

    I hear you.....I am aware of that.
    When I wake it up I get 0.0...then step on it and 0.0 is still there for 5 sec, and then dissapears for 5 sec, and then comes back again...and so on.
    I have not gotten one reading of weight yet.
    Garmin Connect says I am running 2.60 software.
  • Did it ever get fixed - mine is doing the same thing

  • Mine too does this. Haven't been able to use the scale for well over 6 months now. No solution to be found. 

  • Would like to know as well if this issue was resolved! Mine has been doing this for about 2 weeks. Extremely frustrating. 

  • Nothing yet. Haven't done much about it either. Will contact Garmin soon. Did you do anything on the scale when it happend? I think the problem started after i changed batteries. 

  • We actually switched batteries recently as well. I would say it worked a handful of times after we changed batteries but then nothing. I would say it started less then a week from changing them. 

  • Hello ppolla,

    Has your problem was ever resolved? I am having exactly the same issue here with newly purchased scale.

    After hours of trying i have contacted Garmin Support and they have told me that they will investigate it, without giving any time frame.

    Extremely frustrated.


  • Same issue here. Expensive stuf with issues ? Hope you did get answers yet ...

  • Hey there, 

    It did not get fixed, but Garmin kindly agreed to replace my device. Anyway I replaced at retailer. 

    Other than that, scale works fine for past 6 months.


  • I did remove the back panel (2 small screws in battery compartment) and i saw 2 wires that where broken. The quality of the soldered wires is BAD. 1 x bend and already broken. So dont touch the others, just check if they are lose.

    In my case the repair (2 minutes work with a solder iron and my close glasses) of the 2 broken wires solved my problem.

    It is quit expensive, 2 small pcb's with a glass plate for so much money. And such a cheap assembly. Not worth the price we payed.

    Good luck there, and keep in/on the balance

    Greetings from Belgium