This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

WiFi issues on Edge 1000 after upgrade to 15.40

After upgrading my Edge 1000 from 15.20 to 15.40 I noticed that the Edge does not connect to my Home network WiFi anymore. The connection was setup and did work before with 15.20.

My Home network is WPA2-PSK but the Edge shows it as unsecured. Restarting the Garmin and new setup does not work (likely because the WiFi network is assumed unsecured and not WPA2-PSK). The Garmin still connects though to my iPhone personal hotspot.

Home WiFi network is Ubiquiti nanoHD (802.11ac Wave2) Firmware 2.4Ghz and 5ghz are botj enabled. SSID is not hidden.

Anyone else experienced something similar?

  • I haven't experienced this issue, but you might need to setup WiFi in Garmin Express again

  • I tried that, too. Although I can setup and define the WPA2 network via Garmin Express later when I try to connect on the Edge I get a failed to connect.

  • After I disable fast roaming support (802.11r) the Edge reconnects.

  • I have the same issue. Even did a full reset on the Garmin and no joy. The fast roaming switch does work, Thanks to @ . I run a Deco WiFi and as soon as I switched this off, the Garmin connected. Downside, is once I reinstated the fast roaming, I again lost the Garmin connection. Need a fix in next update.

  • any update from Garmin on this?  just upgraded to a 1030Plus and google led me here.  don't have an issue on my 830 or the old 1030 and 802.11r will probably just get more widespread as people start adding mesh networks to their homes.  


    i re-enabled 802.11r and the garmin retained the connection.  if i try to re-add, then it shows unsecured again, but looks like you just have to disable 802.11r temporarily to make the initial connection.

    scott / / live wind on your garmin

  • I have a mesh system. I also have the issue of the insecure wifi network. But that is not true off course. I solved it by adding my wifi network manually within my edge 1030.

  • I have the same issue with my Edge 1000, firmware version 15.50: Failed to connect to my WiFi (wireless mode 802.11b/g/n mixed). When searching (Add Network), I've got: "No network found nearby.". I've added manually my Network(SSID) using Garmin Express, but still not working(Failed to connect to WiFi). The Edge 1000 WiFi was working with older version than 15.40 I think. On my router there is nothing sucha as fast roaming support.

    Is there someone who can help with this?

  • Same issue with Wifi --- connects but does not show option for WPA2 security

  • I'm having the same issue went out yesterday for a 46mile mtb slogg, got home saved the ride Thumbsup Went to sync it to Garmin connect nothing? Also stating no network found even though my network is saved on the 1000. My last ride was back in August 2020 and that synced fine! I followed the support guidance and led me down the route of doing a hard reset and I've lost all my data, even though it states you will not lose any data or settings and I've lost the lot!!! 

  • In my case I changed my WLAN to 5 GHz, and since then my Garmin Edge 1000 (FW v. 15.50) is unable to connect to _any_ WLAN network. Steps I tried until now:

    1. Switched back to the old 2.4 GHz WLAN. 
    2. Switched from automatic channel selection in WLAN settings to a fixed channel, as suggested in another forum. 
    3. Added my WLAN manually, as the Edge does not find it. Fruitless effort. It seems to find some WLAN networks when I turn its WLAN setting on, but not mine. Adding the SSID manually and trying to connect leads to the "failed to connect to [Name_of_WLAN]" error. 
    4. Removing and adding WLAN Networks via Garmin Connect App. Still no success.

    As I know, there is an initial config of WLAN settings which you have to to via the Garmin Connect App. If I can do this without resetting the device and losing all my settings, I will try this. Otherwise I will resort to bluetooth for syncing. 

    Conclusion: Typical Garmin Software functionality, which is incredibly crappy programmed and a shame for a market leader in GPS devices. I never had any other smart device which is so poorly in using its hardware features (e. g. having WLAN connectivity _and_ Bluetooth but not able to just download/sync .gpx files without connecting it to another device via USB – dafug?! Wahoo provides this from day one!).

    If anybody would provide a hack of the firmware I would gladly try it out.