This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

12.30 was working fine for me and 12.40 almost break my device

Yesterday I used my Edge 820 after long time because of the CORONAVIRUS pandemic issue. It had the v12.30 since I uploaded the software recently and all the sensor worked fine. The only issue that i have and i actually dont know why is happening is the device fails to connect bluetooth via to my Huawei Nova 5T device with android 10. I almost all the time need to unpair on both devices and start the process to pair them from scratch, another thing is that the smart notifications doesnt work on my garmin, just notifications for missed calls that curious i can reply with a message from the garmin device.

Now with this roll back that you apparentely did to v12.20 (v12.40) my garmin was stuck on the GARMIN splash screen (no additional messages or anything else on the screen). I even tried to connect it to the GARMIN EXPRESS and it was not responding at all, the my computer didnt recognize it as external storage device as it usually was recognized.

Now since it was stucked there i did a hard reset on the unit, same thing stuck on the GARMIN splash screen, but with something different, there was a message on the bottom of the screen of Copyright 2016, subsidiaries, something like that. Then remained stuck there for several minutes. Again I did like 2 more hard resets for the same situation, in all of them the device rebooted itself, I didnt need to power on it myself. Later I rebooted again and voilá I got the message of update succesful. It stayed loading maps for a little while and entered on the main screen to choose the ride mode.

Now connected to GARMIN EXPRESS appears to be working normally as a external storage device.

I just wanted to share my story in case someone face a similar issue, hoping you can respond for the phone connectivity issue as well.