This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Pairing fails with Android 13 phone

My Edge 820 and Pixel 4a5g phone have been paired with no problems. But I updated the phone to Android 13 2 days ago and, since then, the connection stopped working. No problem, I thought, I'll just remove the device in Garmin Connect and then re-add the device. I removed the Edge 820 from the phone's list of bluetooth devices, and used "Forget phone" on the Edge before attempting to Add Device again.

I have now attempted numerous times to add the device in Connect with varying results, but the end result is always a failure.

In the list of BT devices that Connect shows when you start the Add routine, the Edge sometimes shows up as "Edge 820" and other times as "BT_Edge 820".

When it is Edge 820, I get taken to a screen to confirm I want to pair, and then get the 6-digit code on the phone and device. I confirm at each end and the pairing progress bar appears but never get to the end before I get a "Pairing failed" screen in Connect.

When it is BT_Edge 820, I just get a spinning circle for a few seconds and then get taken to the device selection screen,

I've followed all the troubleshooting tips, but no success.

As an aside, I had to go through a similar rigmarole in having to re-pair my Fenix 5+ watch, but eventually it worked.

Has anyone else tried pairing an Edge 820, or any other device, with an Android 13 phone? How did it work out?

  • OK, got it working in the end. I tried pairing first in the phone's native bluetooth settings screen and, when that was done, went back to GC and added the device. There were a few pairing request notifications that I had to acknowledge and, ultimately, my Edge is now showing up in GC. Never had to do this before (with numerous Edge, Forerunner, and Fenix devices, and earlier versions of Android), in fact I thought we were positive discouraged from adding the devices in the phone's native BT settings prior to adding in GC. 

  • Yeah.  Normally you have to add only through the app and not the phone's BT settings.   What I've done in the past is remove the 820 from the phone's BT settings.  Uninstall Connect on my phone, then install Connect again and go through the pairing using the app.  That's always worked with the phone BT connection got f'ed up for some reason.

  • I just updated my Pixel 5 to Android 13, and have started having issues with my Epix 2 getting disconnected, and the refusing to reconnect.

  • I just got a pixel 6 which updated to Android 13 and a Garmin Edge 830 and it won't pair. Tried everything.

    It pairs on my old pixel 3 on Android 12. Had I known Android 13 had issues, I wouldn't have updated the OS.

  • This is doing my head in. I'm finding now that my Fenix 5+ is disconnecting from the phone at least once a day, and it's a royal PITA to get it connected again. Sometimes I just need to toggle BT on and off on the phone, but sometimes I have to reboot the phone before it will reconnect.

    I'm assuming this is a problem with Android 13 rather than the Garmin products, but I wonder if Garmin themselves should liaise with Google to get it fixed? 

  • Also having same problem with Android 13, tried every trick on the web and still pairing fails. Come on, Garmin, help us out here

  • Me ocurre lo mismo. Xiaomi Mi10 T pro actualizado a Android 13. Desde entonces imposible emparejar con mi Garmin Edge 830. Problemas en la vinculación como os ha ocurrido al resto. He escrito al soporte de Garmin. Esperando respuesta.

  • Hi

    I can confirm that similar not syncing and/or pairing issues are with Fenix 5 (fw 25) and Google Pixel 4a with Android 13. Have tried to factory reset both phone and fenix watch. No success. After several tries, it's possible to pair watch with phone, but after syncing once, it's impossible to sync again. 

  • Hola. Lo acabo de resolver haciendo un downgrade de la aplicación de Garmin Connect. He instalado justo la anterior la 4.58 en lugar de la última la 4.59 y me h emparejado a la primera

  • Haz una downgrade del Garmin Connect. Yo instale la versión 4.58 en lugar de la 4.59 y me ha emparejado a la primera. Os dejo el enlace de donde podéis descargar las versiones anteriores. Un saludo.