This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

FR955 Severe bug: Watch restarts if you press any button other than Light if you disable backlight.

In settings I disabled backlight until sunset to save battery, and it took me a day to find out why my watch kept restarting when I pressed any button. I really hope the QA team forwards this to be fixed asap. As for anyone else who has this I hope I save you the time of resetting & re-configuring the watch.

  • The same, without trying the music. FR955 Solar. I did not know it was the backlight settings, that was set to off during the day. At that point I created my own watchface (which I cannot remove now, there is another topic created about that on the forum) I thought it is my or some other watchface I downloaded...or maybe related to I managed to reset the settings just after the watch booted. Thinking even about returning the watch while I still can and stay on half of the price Polar.

    Reset settings deleted all watchfaces except for mine. I had to set everything up again, the most frustrating thing...adding activities and data fields. Funny, I missed the backlight option on my second setup and it did not restart on button presses again. After that I saw this thread. The reason for returnig is the battery drain. Went to bed in flight mode ON, 32%, woke after 6:30 hours at battery percentage of 17%?! SpO2 - on demand. I don't get it...all radio was off, default watchface.

    Now it lost 2% in 10 hours during the day, changed the watchface to Fenix like (forgot the name)...which weirdly turns off and on every once in a while...and there is a blank screen..till swipe or button press.

    I miss a way to save or to export those settings, of activity fields + I come from Polar where it is a breeze to do it in Polar Flow on the PC. Why there is missing Max heart rate as an option for a field, don't know. Even though I am in years now, I still hit over 200 bpm.

    Also on Android, the latest Connect version, there are some field when chosen, they show different after saving on the phone. For example when I choose Total Calories, go one step back it says - Running Index. (I downloaded Running index app also). The same for couple of other fields.

  • Hello all, 

    We are currently investigating reports of watches restarting with any button press other then the light button. A work around to that will be to turn the backlight gesture setting off for both "During Activity" and "General Use."

  • I had this issue happen 3 times with the backlight gesture turned off completely. so not much of a workaround

  • So that I may assist you further, please reply with the following:

    1. May we, if necessary, have permission to email you?
    2. May we, if necessary, have permission to view/access your Garmin Connect account?
    3. In what country do you live?
  • ok, I am pretty convinced this is something to do with power management. happened to me again after fully charging the watch. Complete meltdown, any button (except for light) leads to reboot. I put it back in the charger for a second and it was back to normal.

    So this may be a workaround until Garmin fixes this bug. I'm sending them my watch, hopefully they can get this fixed asap.

  • My only helping workaround is to set the backlight gesture AND lighting up with every button press on ON for both "During Activity" and "General Use".

  • So that I may assist you further, please reply with the following:

    1. Yes
    2. Yes
    3. Spain

    I've had the watch for three days and today is when this happened to me.
    It happened in the afternoon when I was putting a protective glass on the watch. I first thought that it would disturb the touch screen and that's why resets would occur. Then I went on the forum and saw that it affected more people and that it is thought to be because of the light.
    I have disabled the light in all situations and it still didn't work for me.
    I tried charging the watch a bit, and that didn't work for me either.
    Then I cleaned the screen well in case it was a problem with the touch screen going crazy from too many keystrokes because of the tempered glass and it worked.
    I don't think it's the touch screen's fault but I'll tell you my situation in case it can help.