This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

sound and visual alerts in workout mode

Hello, is there a way to get rid of the sound and visual alerts while in workout mode with zones HR, W, pace ... to respect. 

I still want to tell the watch I have to run at 140 HR for 45' but I don't wan't it to vibrate and show big visual alerts that I am "in the zone" or that my HR is 143 for 5 seconds.
Is that possible ?

  • Remove alert in settings on your watch. 

  • There is no option for disabling alerts during workouts. It's bugging me like crazy! I cannot believe how this is not in there. I've been asking for it since many years back.

    I. Don't. Want. Alerts. During. Workouts.

    How is this not a bigger thing? Oh well :)

  • Hi, funnily enough I wanted to start a post about this as well! It's driving me crazy too. I have Auto Lap enabled every 1km because I want to keep an eye on my paces but not during my workouts. It seems there is no way to get rid of both Sound and Vibration alerts. It's so annoying!

    Also, when I do Intervals longer than 1km I have to disable the Auto Lap function every 1km otherwise I end up with intermediate laps I don't want. Is there a way to disable Auto Lap while in an Intervals workout? 

    Thanks a lot.

  • There really is! 

    If you are referring to notifications such as text messages then go to 

    settings -> smart notifications -> during activity -> notifications -> off

    If you are referring to alerts then these have been added by yourself, to remove them head to the activity they appear in such as running then press up for options then head to 

    run settings -> alerts -> remove alerts you don't want  

    repeat for other activity types this happens on  

  • I have no alerts configured under settings -> alerts nevertheless I'm getting the Auto Lap alerts and when I was following a Garmin Coach Plan I was also getting Pace alerts.

  • My reply was to cwikdahl

    With auto lap enabled you will always get an alert, you can change the primary and secondary data on the alert but I don't think you can remove it. You might be able to configure it so that there's no sound or vibration though.

    To save your having to enable and disable auto lap each time you can copy the run activity already created and rename it as interval, then disable auto lap for this new activity profile.  This will save your having to remember to change settings each time  

  • When you use the watch in Workout mode, there are alerts when you are outside whatever zone the workout says you should be in. These cover the whole screen and stays for several seconds. Basically you get "You're doing it wrong!" in your face and can't see anything but that ;)

    There is no option to turn these off. I have no alerts configured for the activities I do workouts in. Also have the smart notification off, but that has nothing to do with this issue.

  • I'm don't understand your reference to workout mode? 

  • Do you mean Garmin coach? Or a plan?