This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Pulse Ox not working + Heart Rate not working when Pulse Ox is turned on


Got my 945 yesterday and set it up. Everything seemed to be working fine initially.

During the evening I went through some settings and turned on HRV Logging, Sleep/All-Day Pulse Ox, etc.

After this I noticed all heart rate data started displaying "--" with maybe one value every few minutes at best before going back to "--". Stress measurement started showing "Check watch fit" when trying to do a measurement and I was unable to get a single Pulse Ox reading during the whole evening. I went to sleep thinking it might just need some time to adjust.

I woke up with absolutely no sleep data or HR data for the night. After not getting more than a few blips of wrist heart rate data all morning regardless of restarts, different clock position on wrist, band tightness or even wrist side, I went back into the settings and tried turning off the Pulse Ox sensor. After this the heart rate reading updates reliably every few second and everything seems to work again.

I have now tried this multiple times to make sure. Turning on Pulse Ox in the Sensors menu makes all wrist heart rate measurements disappear and turning it off makes them work like normal again. No Pulse Ox readings have been captured at any point and can't be captured manually either.

Anyone have any info on this? Some known software issue, a faulty sensor, something else?

Software version 2.60 (2fa11e6). (EDIT: upgrading to 2.64 beta or downgrading to 2.50 does not help. Neither did 2.70.)

Lights on the back of the watch seem to work quite differently when Pulse Ox is on, cycling through a blink pattern if that is of any value, but I have nothing to compare to. (EDIT: took a video of it since it looks like the sensor in an endless reset loop: Local Garmin support said it does not look like what their test unit looks like)


  • Former Member
    0 Former Member over 4 years ago

    For all the people asking "why bother with pulse ox" i can say mine regularly drops to 90% (as measured with a clinical device) so having this data available on my wrist at any time would be very useful. My 945 is a revision c version with the bug, so i'm patiently awaiting Garmin to fix this with a software update.

    Now you're thinking "why does his pulse ox drop to 90%?"

    Yes i can cycle 100 miles non-stop, yes i can walk 20 miles non-stop (did it yesterday) but  ..... asthma sometimes kicks in.

  • Just to be clear, I've never said "why bother with pulse ox", I was just curious to know why people need this data so much.

    Thank you for your comprehensive answer.

    The first two people who answered just want some new fancy data on their dashboard I guess.

  • Hi Steve, can I see somewhere in the watches menu what hardware revision are my FR945?

  • I just got my FR945 today (Rev. D). I don't know if it's related or if it helps, but after setting up the watch (including connecting all sensors) I saw the very same behavior. By coincidence I found out, that the watch kept connecting to my Polar OH1 which was charging. I turned off the OH1 in the sensor settings and everything was back to normal.

    Btw, I too need PulseOx because of sleep Apnea. But even if I didn't need it, it would be unacceptable if it didn't work. I paid for this watch with all it's bells and whistles. Whether I need it or not, it has to work properly. 

  • I have the exact same problem, not sure what revision my watch is though (I'll check the box later) but I bought from Wiggle UK, so I guess its  rev C like everyone else.

    Can someone confirm if Clever training are sending out Rev D's?  If so I'll send this back to wiggle and buy one from clever training instead

  • I have rev C from wiggle and having the same problems. This is the second one they've sent me (first one had a problem where all sensors would stop working randomly) so don't want to wait for another one. Hopefully there's an update that will fix it.

  • Just got off the phone to Garmin again who are refusing to acknowledge this is a known problem, but they have raised an investigation and are 'looking into it' but also wouldn't give me a timeframe for how long this will take before I hear anything, so I guess its how long is a piece of string. 

    I do have a revision C from Wiggle.  Updated the watch last night to 2.80, with hard reset and still not working. Even when I turn the Pulse OX sensor on it doesn't seem to work at all, but when its turned on it still breaks the heart rate, stress and body battery sensors. 

    I'm tempted to just send this one back to Wiggle (by the way there customer service is even more shocking than Garmin's) and just buy one from Clever Training and how i get the Rev D from them. 

  • Ben,

    Prompted by your post, I called Garmin. They immediately acknowledged that this is a known issue and told me that they are looking for watches with the problem to evaluate. They are sending me a replacement and taking mine in to evaluate.

  • Out of interest, do you have to send your watch back first before they exchange it? I'm willing to do the same but I don't want to be without a watch for a period

  • Thanks mate, that's reassuring, must be different customer service agents then. 

    Where did you buy yours from? I just ordered another from wiggle and will return this current one to them for a refund.  The new one is coming tomorrow so will update if it has the same problem or not, I've been reassured by the wiggle bloke that 'they haven't had many reported problems' to them even though this thread says differently, fingers crossed!

    I'm worried that it's a hardware problem and not just a firmware problem since some seem to be working and some dont