This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Pulse Ox not working + Heart Rate not working when Pulse Ox is turned on


Got my 945 yesterday and set it up. Everything seemed to be working fine initially.

During the evening I went through some settings and turned on HRV Logging, Sleep/All-Day Pulse Ox, etc.

After this I noticed all heart rate data started displaying "--" with maybe one value every few minutes at best before going back to "--". Stress measurement started showing "Check watch fit" when trying to do a measurement and I was unable to get a single Pulse Ox reading during the whole evening. I went to sleep thinking it might just need some time to adjust.

I woke up with absolutely no sleep data or HR data for the night. After not getting more than a few blips of wrist heart rate data all morning regardless of restarts, different clock position on wrist, band tightness or even wrist side, I went back into the settings and tried turning off the Pulse Ox sensor. After this the heart rate reading updates reliably every few second and everything seems to work again.

I have now tried this multiple times to make sure. Turning on Pulse Ox in the Sensors menu makes all wrist heart rate measurements disappear and turning it off makes them work like normal again. No Pulse Ox readings have been captured at any point and can't be captured manually either.

Anyone have any info on this? Some known software issue, a faulty sensor, something else?

Software version 2.60 (2fa11e6). (EDIT: upgrading to 2.64 beta or downgrading to 2.50 does not help. Neither did 2.70.)

Lights on the back of the watch seem to work quite differently when Pulse Ox is on, cycling through a blink pattern if that is of any value, but I have nothing to compare to. (EDIT: took a video of it since it looks like the sensor in an endless reset loop: Local Garmin support said it does not look like what their test unit looks like)


  • Former Member
    0 Former Member over 4 years ago in reply to chaplainlt

    I'm going to try to return mine too. "Upgraded" from a Polar vantage V and after that had buttons issues so had to repaclace the unit. And the Pulse Ox doesn'tt work in the replacement. And Garmin support haven't even bothered to contact me for this issue after almost a week since I contacted them.

  • Former Member
    0 Former Member over 4 years ago

    Just received my 945 from Wiggle in the uk, with exactly the same problem and symptoms as others have mentioned in this thread. I'm leaving Pulse Ox switched off for now to maintain reliable 24/7 heart rate recording. Sooner or later Garmin will resolve the issue. As a maintenance engineer of 30 years i've seen firmware/software bugs so many times on such a wide variety of new machines/equipment i feel it's just a standard thing nowadays. 

    In other words ... no need to throw your rattle out the pram and return your new 945 to the seller.  The "physical" parts of it are fine, the software inside is at fault. No doubt one of Garmin's software writers have made a typo (seen it before on industrial machines) and it's going to take time for someone to read through the code and identify the problem.

    Owner of Garmin Edge 800, 520, 1000, 1030, GPS64S ... i've seen bugs in them all which have been resolved WITHOUT posting the units back. 

  • Not sure about that.

    Upgrading/downgrading the watch or sensor firmware of an unit with this issue to versions that work with other units does not help. These other units are working fine with any of the same software versions. So unless the bug is something like an updated sensor model number of changed hardware present in these faulty units that's been typed wrong in the configuration or a different init procedure it requires being missing, it will be harder to fix with an update. This is not a typical "new firmware messed up functionality" issue.

    The sensor itself seems to abruptly lose power when turning on the red pulse ox measurement lights, so this could also be a hardware or power distribution problem.

    My fear is if it's a bad hardware configuration or batch (and since it might be quite widespread in the newer production run) Garmin will "fix" it by working around it in software. If a watch from this batch is detected, the patch will use a lower power mode for the measurement even if it affects the results negatively. I make sensor software for a living as well and this is how we fix botched installations without having to recall hardware Slight smile

  • Update: Got a message from Garmin support. They say they've now received multiple reports of this issue but that a solution for it has not been found yet.

  • Hi , I've just got my new 945 and I have been facing the same problem with Pulse OX on.

    Did Garmin say to you if it is a software's issue or it's an hardware's one? because  when I immidiately contacted them, they said to send it to warranty but if it is a software's issue this would not have any sense.


  • Garmin advised me about a week ago that this would require a software/firmware "patch" that they would issue.  

  • I work in software also. And I afraid I'm more inclined to hardware problem than firmware.

    I do not like the idea of using firmware to fix hardware faults. I just want reliable data.

  • Actually...

    In the Health Stats widget the sensors blinks green/red as before and seems in "boot loop" (as before).

    The Pulse Ox widget says "measuring" for some time and no red light.

    At least now we are able to run GPS 2.50 plus wrist-based heart rate for swimming.

    FW 2.72 + GPS 2.50 + Sensor Hub 2.32