This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Pulse Ox not working + Heart Rate not working when Pulse Ox is turned on


Got my 945 yesterday and set it up. Everything seemed to be working fine initially.

During the evening I went through some settings and turned on HRV Logging, Sleep/All-Day Pulse Ox, etc.

After this I noticed all heart rate data started displaying "--" with maybe one value every few minutes at best before going back to "--". Stress measurement started showing "Check watch fit" when trying to do a measurement and I was unable to get a single Pulse Ox reading during the whole evening. I went to sleep thinking it might just need some time to adjust.

I woke up with absolutely no sleep data or HR data for the night. After not getting more than a few blips of wrist heart rate data all morning regardless of restarts, different clock position on wrist, band tightness or even wrist side, I went back into the settings and tried turning off the Pulse Ox sensor. After this the heart rate reading updates reliably every few second and everything seems to work again.

I have now tried this multiple times to make sure. Turning on Pulse Ox in the Sensors menu makes all wrist heart rate measurements disappear and turning it off makes them work like normal again. No Pulse Ox readings have been captured at any point and can't be captured manually either.

Anyone have any info on this? Some known software issue, a faulty sensor, something else?

Software version 2.60 (2fa11e6). (EDIT: upgrading to 2.64 beta or downgrading to 2.50 does not help. Neither did 2.70.)

Lights on the back of the watch seem to work quite differently when Pulse Ox is on, cycling through a blink pattern if that is of any value, but I have nothing to compare to. (EDIT: took a video of it since it looks like the sensor in an endless reset loop: Local Garmin support said it does not look like what their test unit looks like)


  • @thib_rcqf @jeomorris @zepinho86 I've heard back nothing more. Both local Garmin support and Wiggle have just said it's broken and needs to be returned or sent in for repairs. I tried asking specifically about if this is a known issue but both said it was not.

    Since there have now been more reports after starting the thread I'm now waiting a few days before returning it, since there might be something else behind it than just a broken sensor on this unit.

  • FYI I also bought mine on wiggle

  • I have the same issue. Received from Wiggle on Monday with 2.6 installed. Garmin advised yesterday to update to 2.64 but it made no difference. They said it should work as their one in the office worked. They thought it must be a fault with my watch. They were not aware at this time of others having the same issue! Very frustrating.

  • Still haven't received any answer on my side :/

  • I've also emailed Garmin also referring this thread. Power to us!

    I will check this night that with Sleep Pulse OX turned off the watch will record sleep data (hopefully).

    After that tomorrow I will update to beta FW just in case... And do a Factory Reset after that just to be sure.

    It seems that I will need to hold back my Fenix 5 resell... It sppears we are in risk to have to send our 945s back to Garmin...

  • Tried Twiter, Facebook, IG nothing till now.

  • I had the same issue.  Received a 945 two weeks ago today and it wouldn't read Pulse Ox.  Garmin support wasn't able to help.  They approved a return and I reordered a new watch that hasn't shipped yet.  I still haven't returned the first one either...  If we knew that this would be a software fix, I'd cancel the return and the new order.  

    I have the same software version (2.6).  The techs I spoke with last Monday weren't able to help or come up with a solution - but did seem surprised that it had version 2.6 on it.  

  • Hi,

    I've just received an email from Garmin saying that they are aware of this malfunction and currently working on a patch.

    So I guess we just need to wait.

  • Confirmed that the watch records sleep ok with Sleep Pulse OX disabled.

    Same as reported before... Beta FW didn't changed anything even with a Factory reset. Problem persists.

  • They have also contacted me today.

    Asked to access my Garmin Connect data and to share an activity manifesting the problem...

    I've recorded 1 minute Treadmill with Oxygenation data fields enabled... Not sure how this will assist them since the problem is also outside any given activity.