BUG: Unable to change CIQ data field without tedious workaround (the full list of CIQ fields is initially unavailable) (15.19)

Observed behavior:

Suppose I have more than 2 CIQ data fields installed on my watch.

If I have 2 CIQ data fields assigned to an activity such as Run and I select either one of them and try to change it a different CIQ field, the watch only shows me a list with those 2 fields (and "IQ Get More", which takes me to a screen which explains how to get more CIQ apps).

If I want to see all the other CIQ data fields, there's two workarounds:

1) Select "IQ Get More", then press Back. (This only works if the activity hasn't been started, and it doesn't seem to consistently work, otherwise.)

2) Change one CIQ data field to a non-CIQ data field, then change it to another CIQ field.


Expected behavior:

When I have 2 CIQ data fields assigned to an activity and I try to change either one of them to different CIQ field, I expect to see the full list of CIQ fields without any workarounds.


Sorry to be a complainer, but it's just another Garmin usability fail. (It's the "little" things like this that are the most annoying, TBH.) It doesn't help that there's no bug reports forum for non-beta software.

It also makes me wonder whether any of this stuff gets tested, and whether Garmin employees eat their own dogfood. Again, nothing against any individuals, but I feel like this is a corporate culture thing.

  • What's worse is I found it's possible to get in this state when there's only *one* CIQ field installed. Now when I select "Connect IQ fields", I only see one item: the currently installed CIQ field.

    This seems to be a variant of the old bug where you have 2 CIQ fields installed, then all of a sudden there's only one CIQ field, but the watch acts as if two are actually installed. Then you have to jump through various hoops to add another field (such as removing the other field).

    I suppose that if I remove the CIQ field I will eventually be able to add both fields back, but it's really frustrating to see the same old bugs recur over and over again.

    EDIT: this bug has some complex effects which makes it very hard to add the CIQ fields I want to.

    - I started with two CIQ data fields (I'll call them A and B) on the same activity (Run)

    - Originally I tried to change A to C (another CIQ data field), but it failed because of the original bug in the OP

    - I finally changed A to C using one of workarounds. (At this point my watch had CIQ fields C and B)

    - I exited the Run activity and opened it again (in between, I did some random testing). At some point, C was automatically removed (by the watch, not me), so now the activity only had B. In trying to put A back, I ran into the 2nd bug: in the "Connect IQ fields" list, only B was available

    - I removed B (replaced it with a non-CIQ field), which caused B to reappear in the original slot for A. I also removed B from A's slot, and finally I had the full list of CIQ fields to choose from. I put A back into its original slot.

    - At this point you'd think everything would be great, but now when I try to add a 2nd CIQ field, I only see A and B in the list. I exited the activity and re-entered it, and B was magically back in its original slot.

    TL;DR the old bug has returned where a CIQ field is either "magically" removed without user intervention, or the user actually removes a CIQ field, but the watch acts as if the field is there. This is exacerbated by the new bug where if you have 2 CIQ fields installed, the watch doesn't show any other CIQ fields in the "CIQ Data Fields" list.

    In the past when I ran into these problems on an older watch (935), it just discouraged me from even trying out new CIQ fields.

  • I will also say that the "IQ Get More" menu item is interesting, to say the least.

    If I select it before the activity is started, it tells me "Additional data fields are available for download in the Garmin Connect app". (I think they meant to type "Connect IQ app".)

    If I select it after the activity is started, it says "Cannot download data fields during activity".

    This suggest to me that it's a placeholder for the on-device CIQ store on newer devices, but they forgot to change the error message that would appear on those newer devices if you tried to use the on-device store during an activity (which is obviously not allowed.) This error message doesn't make any sense on a watch that (currently) doesn't have the on-device store.

    Like I said, it's the little things that are the most annoying. IMO, lack of attention to detail for the small things sometimes translates to even worse problems with the big things.