This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

fw 9.60 issues

after fw 9.60 when i con the 735 with garmin express via usb the watch only stay at chagrin mode ! not show on pc or sinc ! when i take the cable off still stay at chagrin mode!

then ony when i force to   shut  down it wake up !

try hard reset the it connect fine for the 1 time ! and then at 2 time have the issue again

  • Hello everyone,

    I'm experiencing the same issues as everyone else. I tried all your tips to force the sync with my computer but none of them worked. I hope a fix will be pushed quickly. 

    My question though, is it possible to get an update and push it on the watch with garmin connect on my smartphone? Because the Mass Storage mode doesn't work at all on my watch anymore so i don't think i have another option.

    EDIT: Finally managed to make it work using the "turn off when connected to the computer" tip. So either i was doing it wrong or the outcome is inconsistent. 

    I also noticed during my run yesterday that i don't receive a notifcation anymore when my HRM run connect to the watch. I restarted the activity several times but no notification, the strap still connect though but it's rather annoying having to check if the data fields are there before going.

    EDIT 2: Nevermind, i received notifications on my few next runs. I didn't notice any other issue so far.

  • Hello everyone,
    I may have found a solution.
    After several locks after a synchronization, I noticed that if the watch dial was not the default one, the watch remains blocked.
    So, before a USB connection, I set the default dial. The synchronization works and the watch does not stay frozen when I disconnect it from the USB cable.

  • Hello,

    Thanks for your message.

    But please, don't mark its post as answer: we need an update!

  • Okay, I modified it :-)

  • My watch is also freezing when i disconnect from PC, only solution is to shut down watch before connecting to PC.

    Before this "update" i didot have any issues at all

  • Same here. I am nog amused ! watch only one week in use !

  • Yeap. There's a bug in 9.60. Waiting for next update.

  • Same here! BTW this is not Garmin Exp. sync problem. At my linux sysyem without garmin express, if I connect the watch to recharge, the freeze issue appears too! 

    Last couple months Garmin updates made *** devices such as edge 530 beta issues! 

  • Have Garmin made a statement about the bug or update.

  • Same problem here with freezing during usb-connection. Need a fix!