Quitting a Coach training plan not reflecting/syncing to watch

Has anyone else had issues with quitting a training plan and starting a new one, but not having the change take effect in the watch? Mine is still showing the old 10k plan even though I’ve started a new 5k plan. I’ve tried syncing, disconnecting/reconnecting on bluetooth, restarting my watch, restarting yet another plan, running the next activity in my old training plan manually, running the first activity of my NEW plan manually (which, as expected, didn’t factor as complete into my training plan), but nothing has worked. It still is stuck on my upcoming run of the old 10k plan. 

Before I try doing a complete reset/wipe of my watch and re-syncing with my phone/Connect (assuming the activities on Connect will then be re-added to my watch, right? or would the watch actually override and erase the past activities and settings of Connect?) , I was curious if anyone else has seen this issue. Or is there any option i’m missing? Thank you.

  • WOO! I figured out a wonky fix, but in case anyone else encounters it in the future, I'll log it here:

    - in Connect, I paused the new training plan.
    - Synced, and even though the plan I paused was never on my watch, now instead of my widget constantly referring to my old plan's run, it now says "Use Garmin Connect to set up a new training plan."
    - Resumed my new training plan in Connect, after which my watch's widget finally showed the start of the NEW plan.

    That seems to have reset it fine. Keep in mind my new plan was not even started (I couldn't get the Benchmark Run on my watch previously, even) so I had no activities and data to lose.