Calibration is not saved when running on treadmill on FR245. Don’t know what to do

Hi, I would appreciate if the FR245 users who run on a treadmill could tell me if they noticed that they can’t save the treadmill calibration. I have a calibration save issue, that I reported in a previous post.. I have an open case with Garmin. They told me that only 18 other people so far reported this issue, and they will start working on this when they have more people with this problem. I mean 18 is not enough?. I find this totally ridiculous.

First of all, if the calibration cannot be saved, the watch will always report incorrect distance, pace, and speed values when running on a treadmill. For example during a run, instead of 5km it shows 3km. This is a huge huge difference. I have tried everything, I have purchased a Garmin running dynamics pod, but no success. I tried to change stride length, no success.

When during a run this information is so much off compared to the real correct values, I cannot use any of the Garmin features, the laps are incorrect, the speed the pace, the cadence are incorrect or when I use the Garmin Coach, the information how long to run, at what speed, cadence etc. everything is screwed up. At the end of a run, you can specify the distance run but at the next run you have to do it again. Information sent to Strava is incorrect. Garmin admitted this is a known issue, I mean they know about, and they simply don’t care because there are not enough people who reported it.

I really don’t know what to do, and don’t understand why is Garmin behaving like this, I have purchased their product which is not cheap, and I simply can’t use it. I can’t use it really. The reseller who sold me the watch says they won’t take it back because it’s been 2.5 months since the purchase.

I don’t have any idea if Garmin is monitoring this forum, but it’s the only place where I can yell and complain. On the phone with Garmin customer support I already did it without success.

Did any of you went through situations like this?

Anybody else having the same problem? Please