TACX Flow Calibration (again!)

I have had the Tacx Flow for most of this year but the one thing that annoys me is the calibration. With the Tacx Training App it always tells me "Too Loose" on the first attempt even though I have Warmed it up with a 10+ minute warm-up, the tire is at the same highish pressure and the tightness has not been changed since last time, It has never told me "too tight". If I tighten it up more the pedalling is very heavy , so much so that I have trouble getting up to the required 32kph to calibrate.

The Tacx Flow help page https://support.garmin.com/en-AU/?faq=sdgdMoFqDn06eLSYFrnrg5 says "You can use your Edge bike computer to calibrate your trainer" and if I use the 530 it will almost always calibrate first time and has never given the "too looset" instructions even immediately after the App has told me this.

The Flow tightened so the App is happy to calibrate is not an enjoyable experience and I have mostly taken to just using the Edge 530 to calibrate with the looseness a bit slacker. I haven't yet experimented to see how loose the Edge will still allow calibration but am tempted to make the riding a bit better.

The other odd thing is that if I do training (after calibration) with the App controlling resistance then the average speed (say on a flat ride) is higher than if the Edge is controlling resistance even if I keep cadence / power / gearing the same for both and if I set some negative slope training the average speed will be much higher with the same inputs. I am not looking for negative resilience but the App algorithm seems to use the slope when negative to calculate the speed whereas the Edge treats a negative slope the same a 0%

Is it just my Flow or is this a common experience? Thanks