Vivosmart 4 syncs but no GPS

Hi, I have a Vivosmart 4  which syncs as it should and everything was working great until I went for a cycle and the watch prompted me to open the app for GPS signal (this has never caused an issue and has always worked) and I was left waiting for it connect to the phone's gps but never did. 

Things I've tried:

- Un pairing and re - pairing

- All permissions pertaining to connect app on my phone on

- removing device, factory reset, uninstalling/reinstalling app and re-doing the setup fresh

- Switching phone off and on

I'm at a loss. It seems that the connect app is not even requesting location data, because when I use google maps I get the icon at the top telling me it's using my location, the garmin connect app does not show me this (can't remember if it ever did). I am using a Samsung Galaxy S7 and I say that because the watch/app (whichever has the issue) has no issues connecting GPS with my old iPhone 6s. But I don't want to switch phones just to use this watch. 

If anyone can help, please let me know, much appreciated.