Watch unresponsive to touch

Occasionally the watch becomes unresponsive to wrist raise or double tap. Can't figure out how to get to the menu or how to force a power off to restart it.

Sometimes waiting a while resolves this. Today a hard clap of the hands together in frustration caused it to start working again. Didn't hit the watch, just clapped hard and I guess it jolted it awake. When it does work, often have to tap the screen multiple times to register selection or swipe. 

It's only been in use since Christmas with indoor activities. No physical damage, never been dropped, etc.

Is this device defective? Anyone else have this problem? 

Vivomove Style Light Gold.

  • Just wanted to respond to your message yesterday evening, saying that it works fine for me besides when being in strength training. There it tends to freeze, which got better (while still not good) with current software version 3.10. But when I woke up in the mid of the night this morning and wanted to check the time, the watch didn't respond to anything. This was the first time I noticed that. Waiting or clapping didn't work, I had to charge (and so restart) it for it to be working again. Looks like one more bug to me.

  • Mine occasionally does this, I think it might be when it thinks I'm asleep and discards the taps as if it was just involuntary movement?  #notsure

    If I go into the app, it still syncs and stuff, so it's still 'alive' and came right on its own when I tried tapping it again about 30 minutes later (ironically, when I had actually gone to bed).


  • Version 5.20 and the problem still exists

  • 5.30. Still exists. I like my vivomove style overall and using it since November 2019. I am waiting for venu 3 to announce to change my watch however this occasional unresponsiveness drives me crazy and make me question about buying the venu 3. Sometimes I can’t even stop the alarm in the morning because it doesn’t respond to touch

  • This happened to me recently as well - I couldn't dismiss alarm in the morning, but, ironically, frantic tapping on my watch in attempt to dismiss the alarm triggered the Emergency assistance function :-)

  • Same situation here. Got vivomove style as a present for my wife and she's got same problems. However the ios application doesn't see it connected

  • This happens to me as well, and this is on the latest firmware (5.3.0). The common theme seems to be that being in an activity causes the touch screen to fail to respond when an alert comes up, whether that be an alarm or fitness age update (those are the ones I've had repeatedly so far).

    I suspect there's some logic to do with disabling touch in certain circumstances in an activity that isn't handled well when an alert goes off. I do have gesture recognition enabled so the display activates when I look at it, if that makes any difference.

    I'm an EE/SW Engineer so happy to discuss with any of your technical team.

  • I experience the same problem. It does not respond to a single tap but responds to multiple taps and triggers  emergency assistance. 

    I also noticed that connecting the cable fixes the problem but it's frustrating like ***. 

  • Have you tried a full reset (In the watch, Settings -> Reset -> Delete Data and Reset)? I have never had the issue you and others are describing, however a few occasional glitches I have experienced were cured by this.

    If you want to do it, make sure you perform a sync with your phone or Garmin Connect on your PC just before it, so you save all of your stats for the day. Be aware that, even with the sync, the watch will lose all of the settings you may have changed and alarms, reverting to its out of the box default status. You will have to remove it from and re-pair it with your phone and the Garmin Connect app.

  • It has never been fixed for me but I moved on and purchased venu 3 after 4 years of use the watch. So far so good.