This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

How do I turn off the "feature" that keeps turning the display on whenever I move?

Besides wasting battery, the frequent brightening of the display, pretty much anytime I move my forearm, is very annoying.

I want the display to come on only when I press a button or double-tap the screen.

Where is this Setting?

  • Settings->System->Backlight->During Activity->Gesture: Off / Not During Activity: Off.

  • Thanks! The UI is so confounding to me (for whatever reasons), I finally had to look up how to access Settings, and work my way through the path you provided. Much appreciated!

  • My Garmin App doesn't have "Systems" to choose from. Where else could it be?

  • After more research, I found that the setting is not on the app but on the watch itself.

  • Same lol. Then again, I didn’t really thoroughly read the instructions / watch vids and generally learn new tech by doing, but for some reason, I agree the UI on it is very unintuitive.. so yeah  Thx @SfD!

    Btw for anyone else needing even more step by step instructions (and updated at least as of April 2023 with my Venu 2s with a couple slight changes from the above pathway): 

    LOWER RIGHT BUTTON: hold 2 secs -> SETTINGS: swipe up to have it scroll to show the Settings gear wheel at the bottom -> SYSTEM: keep swiping up to scroll down for more options, system is the last one (ofc it is…Stuck out tongue) -> DISPLAY swipe up to find it; it’s the 4th in the list of options -> NOT DURING ACTIVITY > GESTURE - Turn off.

    btw the ‘during activity’ would be to have it while doing a workout /run etc. so most ppl leave it on there so you can run without having to click the screen, but up to you if you wanna change that setting here too. 

  • thank you so much, really helpful

  • Thank you so much, really helpful advice only getting 4 days battery life out of watch, noticed clock display always on..