VA4 loses position in podcasts - known bug?

I sync podcasts using Garmin Express and iTunes, to listen during my runs. But when I return to the same episode on my next run, the watch has totally lost the position - usually 30+ minutes behind.

Fast forwarding is excruciatingly slow and cumbersome to use. I'm quickly going to want to return the device if I have to do this every workout.

Is this a known issue with a fix in the works? This was one of the key features I chose the VA4 for, so it's especially frustrating (also considering the price). I haven't tried it with regular music to see if it is unique to podcast playlists only or not.

  • Now Garmin Express can't even locate old podcasts that are on my watch so I can't delete them! I've tried refreshing the music page in Garmin Express, restarting my watch, restarting Garmin Express, and rebooting my computer and nothing has triggered Express to see my old podcasts.

    I sure am glad to have received a helpful response and acknowledgement of my previous post from over two weeks ago. What a wonderful AUD$550 investment this device was, since there is clearly such a responsive and helpful software team at Garmin...

    I can't believe how buggy this thing is, and at this price point.

    [EDIT: For anyone else with this problem, here's the ridiculous workaround I found for this bug: re-send the same music/podcasts to the watch (that are technically already on the watch but Garmin Express is not detecting); then they will show up again in Express and you can remove them from the watch.]