Brightness setting does not work

The brightness setting doesn't work and seems to be fixed to automatic.

There is a brightness setting on the watch to adjust the brightness manually. However, it doesn't do anything. It seems the brightness is set to automatic, unable to change the brightness setting to manual.

Is everyone with the Venu experiencing the same issue?

  • Upgraded to 3.5 same issue.  Think everyone should email support.    Not sure they know this is a pain.   Or who it is affecting.  

  • I also faced this issue, anyone has a solution?

  • I have been working with support.  So far they had my hook it up to Garmin Express to verify it was up to date (it was),  And next was to send them a video and screenshots.  And I pointed them to this thread and one on reddit..  Other people probably need to call as well.

    Wearing my Samsung Galaxy Watch Active 2 at the moment until they fix it.

  • But it is not a big issue. With always on i came 3 days and without always on i came 5 full days (and had 22% left). A lazy week ;) But if you make sport, GPS or Music are the Battery killers. On a 3h hike, i lost 26% Battery with always on.

    So, the brightness settings would be fine if they work. But i assume a big benefit will not be there... The automatic brightness works well (display is brighter in sun and darker in rooms...).

  • Original poster here. I also don't think this is much of an issue. Probably I would have set it to auto brightness anyway.

    But the response and how Garmin is acting on this is ridiculous. No responses, acting like this is a new issue with every report is unacceptable. Not looking at the forums as if Garmin support people are not allowed these read their own forums or pretending these forums don't exist.

    This my first Garmin product, was it always like this?

  • Yes, it is always like this ;)

    BUT: I came from Fitbit and it was much, much more worse. Some Bugs where not fixed for many years (had an issue in 2017 and found first posts from 2015 -> map+activity not shown in dashboard, data lost, not a small issue).

    After Vivoactive 3 (my first garmin), then Forerunner 245 and now Venu, i an say that many start issues are solved over time. Comparing with the VA3 start (i also had it when it came out), the problems with the Venu are very, very small... i am hapy with this start. And when the first issues are solved, i am more happy than now.

    I think the problem here with garmin is, that they have so much devices and have to to keep up to date. In future, it could be a problem... but overall i did not found a replacement (i tried all... fitbit less sport, bad support ; Samsung: i don´t like the app but very good watches ; Android Wear -> bad battery and so on ;) and none of them have a Web Dashboard (just Polar), so Garmin is my best choice currently ).

  • To you its not a big deal.  It is too bright for me in the dark.  And tends not to be bright enough when I need it.  I always manually control all my devices.  Everybodies eyes are different.

  • Same here. Noticed it the other evening. Can confirm I'm on the latest software / fireware etc.

  • Same here. Noticed it the other evening. Can confirm I'm on the latest software / fireware etc.

  • Yep, I have the same issue on SW 3.50. When you adjust the brightness nothing happens, additionally I'm finding the auto brightness really hit or miss, it jumps around constantly.