Inncoming calls on Venu 3S

Just got my Venu 3s.. When i got inncoming calls, the watch only shows the callers phonenumber, not the name that stands in my contactlist.. How do i fix this?

Top Replies

All Replies

  • Make sure you've installed the latest version of Garmin Connect Mobile iOS

    Then this from the Venu 3 manual - Review App Permission Settings

    • Open the Garmin Connect app.
    • Access the menu by selecting More (bottom right).
    • Scroll down and select Settings.
    • Select Phone Permissions.
    • Select Manage Permissions.
    • Your phone settings should look like the screenshot below.

    Do the same for the Garmin Connect IQ app if it's installed on your phone.

    Also, see manual - 

    NOTE: If you receive a phone call from a contact that has not been added to your Contact List inside of the Garmin Connect app, you will not see the name of the caller on the watch. To set this up please see: How Do I Add Contacts in the Garmin Connect App?

  • I was having the same issue. It was fixed immediately after I gave connect app permission to contacts and phone.

    For android you gotta long press on the app / app info/ permissions