Unable to connect headset

Anyone having issues connecting a bluetooth headset to the Venu2?

I have tried 3 different sets - no luck.

I have tried again after restarting the watch - no luck.

Have tried unpairing the headsets from the phone before pairing to the watch - no luck.

1 shows up, but after selecting it the pairing fails.

Any suggestions?

  • Hello! Can you plug the device into the computer sync with Garmin Express. Unplug them and then be sure the headphones are not connected to anything else. Put the headphones in pair mode then on the device itself select add new under accessories. Please let me know if this works. 

  • The only issues I had was that i'd forgot to switch bluetooth off on all devices to which my headphones were already paired, and its that long since I paired them to anything that I forgot on mine (CA Melomania 1) you only put one of the buds into pairing mode. After that it worked first time.

  • Ended up resetting the watch. Tried again 2 of 3 headsets connected. However my Bose QC Earbuds did not connect at all - too bad since it is my fav headset. It shows up on the watch in connect mode, I select it, it tries to connect but fails every time. Seems like they are not compatable (yet hopefully).

  • Hi Amber. Did this after my reply above. Connected it to Express. When I unplugged it returned an update message. I updated. Reset my Bose and turned off BT on the phone. Bose is found on the watch, it tries to connect but fails in the process in the end. Could be a compatibility issue?

  • Hey! I do not see why it would not pair. The good thing is headphones are connecting. Are you making sure they other headphones are not in range and the Bose are in pair mode first then selecting add new?

  • Hi Amber. Sorry for the late response. Nope didnt work. The watch finds the headphones, then when selected on the watch it is connecting, the headphones seems to connect (light changes from blue to white) but shortly after i get an error message on the watch saying they cant connect.

    Seems to be a problem with the watch and this model of Bose headphones. Venu 2 is the only device so far the headphones have not connected to. Hope this could be fixed with a software update at some point.

  • I have same problem with my venu 2s. Tried 3 sets and with my jbl 500bt find it but then link failed message

  • I got the exact same problem with Venu 2 and Bose Soundsport headphones.
    No other Bluetooth device is turned on in range.
    - set the headphones to pairing mode
    - Settings -> music - headphones -> Add new
    - Finds and displays the headphone correctly
    - Select it
    - "Pairing failed"  message.

  • For future reference people having the same problem.
    "Apparently" Venu2 won't pair with your headphones unless it is the first device to pair with it. I've noticed this luckily because Soundsport has feedback about current devices it's connected/connecting to. And despite headphones saying "connected to... watch" Venu2 failed the connection.

    - I reset the headphones so none of the previous BT connections exist on it.
    - Paired with venu2 first, this went through without problems.
    - tryied playing some music on the watch -> success
    - paired it to my phone (now both phone and watch are paired) I can connect with both devices no problem
    - paired to my laptop(s) and now it has 4 paired devices and all work fine.

    the only problem as far as I can see is Venu2 is unable to pair unless it is the first device on the headphone.