Edge Explore goes blank and locks up during ride

Had my Edge Explore screen go blank and lock up twice during yesterday's ride.  Started late last year and is now practically an every ride thing.  When it happens the device is completely unresponsive.  After a few minutes, holding the power button for 10 seconds brings it back, and when it comes back it's aware a ride is in progress and the data from the earlier part of the ride is intact.  It used to initiate a crash alert during most of these lockups until I disabled it and deleted my emergency contact.

Is anybody else having this problem?  I see it mentioned on the Edge 830 forum.  I began the repair process (I'm out of warranty) and was quoted $130.  I don't want to do it and just get sent a refurbished unit that has the same issue.  My device worked fine for a year.  Then the issue started, I believe after a software upgrade....

  • Because you think a firmware upgrade may have caused the problems...

    If you are in the mood for some experiments, you may install firmware a few versions older. Say version 4.40, or still older. Older versions can be found here: http://gawisp.com/perry/edge/ Look for the file EdgeExplore_440.gcd, rename it to GUPDATE.GCD and copy it to the folder ..\Garmin on the device. Detach the device in a clean way ('Safely remove hardware'), and install will start when the device has rebooted. If not, start the install manually: Menu / System / About / Software Update. Be aware that all your personal settings are lost and have to be re-entered if you downgrade to an older firmware version.

    Now with the older firmware check if the lockups persist, preferably with settings as basic as possible (no Bluetooth, no IQ Apps, etc.). Stepwise from here you hopefully can nail down to the cause of the lockups, by enabling functions one after another, install newest firmware, etc.

    If this sounds too complicated and at least it is time consuming, I'd go for the referb or even maybe a new device.

  • for what it's worth: I have the same problem with my Edge Explore (november 2019), software version 5.1. I think it has to do with a bug in the battery save mode, the screen goes blank, but the device still responds to touch commands and is still navigating (beeps).

    Holding the power button long enough to re-start is indeed the workaround, though on some occasions I did remove the course (not able to see which touch command I gave)

  • I'm experiencing the same problem as the OP except with a brand new device on 5.10. So to answer the OP it could be very well related to the upgrade to 5.10

    I planned route ... started riding and it crashes after 5 km, the only thing I could do was to push the power button for 10 s,it it also sends an emergency message to my assigned emergency contacts. After 30 km the same scenario, it send an emergency call even with the emergency call disabled.

    The next day I connected it with GE, stating the software was up to date, but the maps needed to be updated, so I installed a new map. Besides that I also did a system reset (incl erase data), some fora claim it might be fixed by doing that.

    The next ride, without a planned route went smooth (35 km) so I thought the problem might have been solved.

    Two days later I plan a route of 35 km, after about 5 km ... dang!, crash again, luckily I removed my emergency contacts (since disabling the emergency call was not enough), 10 s power button, .... ok back on track... all went well until the 30th km ... crash again..

    Please note : the battery was far from empty, the first crash on the two rides it was near 100% and the only way to light up the device was pressing the power button for 10 s.

    I was a bit frustrated so I will send it back this noon to the vendor. Since i'm a bit IT minded (rooting android devices, etc) I could do the software downgrade, and hope it fixes it, but what about warranty...