This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

Garmin edge explore 2 stuck in OS 5.09


I'm French and I bought the Garmin Edge explore 2 in July 2022 and I'm very satisfied of it. Unfortunately, I have never succedeed to update my devide (Indeed, it is stuck on OS 5.09 since the begginning).
First of all, I tried to update the Garmin by the "Garmin Connect" app from iPhone but the update failed.
Then, i tried to did it by the "Garmin Express" software from my mac but the Garmin Express tell me I'm already up to date !

I also checked if the file GUPDATE.GCD was not in Garmin folder but it's not the case.
What can i do to update my device ?

Thanks a lot for your help.

  • J'ai eu le même soucis et c'était causé par le fait que je n'avais pas terminé toutes les étapes comme l'envoi de position pour danger. Il faut rentrer un peu dans toutes les rubriques pour valider qu'on ne souhaite pas les utiliser. Hope it helps.